Bug 1459219 - Broken link to help information about post hooks in edit BuildConfig
Broken link to help information about post hooks in edit BuildConfig
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.5.1
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Jessica Forrester
XiaochuanWang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-06 10:44 EDT by Bosse Klykken
Modified: 2017-08-16 15 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Documentation links to the build hooks topic were resulting in a 404.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-10 01:26:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github openshift/origin-web-console/issues/1650 None None None 2017-06-06 10:47 EDT

  None (edit)
Description Bosse Klykken 2017-06-06 10:44:56 EDT
Description of problem:
When using the web interface to edit a BuildConfig, and choosing "Show advanced options", there is a "Learn more" link next to "Post Commit Hooks". This link is broken.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. In the web interface, edit a BuildConfig
2. Choose "Show advanced options"
3. Click the "Learn more" link next to "Post Commit Hooks"
4. 404

Actual results:
A broken link to https://docs.openshift.com/container-platform/3.5/dev_guide/builds.html#build-hooks

Expected results:
A working link to https://docs.openshift.com/container-platform/3.5/dev_guide/builds/build_hooks.html

Additional info:
I have not sourced this bug upstream, as it seems to be OCP related.
Comment 1 Bosse Klykken 2017-06-06 10:45:57 EDT
Correction: I've found the same issue upstream, and submitted a patch
Comment 2 Jessica Forrester 2017-06-07 09:59:27 EDT
We will get a redirect in place to fix 3.5, thanks for the patch for upstream.

adding alex to CC to let us know when the redirect is ready
Comment 3 Jessica Forrester 2017-06-13 14:13:44 EDT
There is a partial redirect in place for 3.5 so the link will not 404 but it will not go to the hooks sub-page for builds.

For 3.6 it is fixed in https://github.com/openshift/origin-web-console/pull/1694
Comment 5 XiaochuanWang 2017-06-28 21:33:09 EDT
Link is correct now in OCP 3.6:
OpenShift Master:  v3.6.126.1
Kubernetes Master: v1.6.1+5115d708d7

https://docs.openshift.com/container-platform/3.6/dev_guide/builds/build_hooks.html
Comment 7 Jessica Forrester 2017-06-29 07:36:58 EDT
I'm not sure what the question is? As part of the PR I swept through every help link we had in the code, they are all maintained in a single file. There were several other links that no longer resolved to the correct topic so I updated them as well.

The links in origin are all correct now. The OCP links will 404 since the 3.6 docs have not been released yet.
Comment 9 errata-xmlrpc 2017-08-10 01:26:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.