Bug 1459332 - Lack of specificity of the error messages from openstack command
Summary: Lack of specificity of the error messages from openstack command
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-openstackclient
Version: 10.0 (Newton)
Hardware: All
OS: All
low
low
Target Milestone: Upstream M3
: 13.0 (Queens)
Assignee: Julie Pichon
QA Contact: Roee Agiman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-06-06 20:12 UTC by Marc Methot
Modified: 2020-07-16 09:46 UTC (History)
7 users (show)

Fixed In Version: python-openstackclient-3.13.0-0.20180109064941.8c5f755.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:31:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 519831 None master: MERGED python-openstackclient: Show detailed message of neutron exception (I8ba694bda86f7cc8362e301b2044d9b610dde49c) 2018-02-07 14:14:41 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:33:17 UTC

Description Marc Methot 2017-06-06 20:12:16 UTC
Description of problem:
Client reported that on OSP 10, when encountering errors, the  messages provided by the "openstack" commands are at times much less meaningful than their older counterparts (neutron, nova, etc.) In this case the "network" plugin.

For example when encountering a quota on total number of rbac, we get the following error : 
~~~
openstack network rbac create --action access_as_external --target-project e308b6b702ea46918752cdaeb932bff8 --type network ce629dbc-b24b-4d57-b988-81879db62eea
HttpException: Conflict
~~~

Whereas the equivalent "neutron" command gives us more explanation :

~~~
neutron rbac-create --target-tenant e308b6b702ea46918752cdaeb932bff8 --action access_as_external --type network ce629dbc-b24b-4d57-b988-81879db62eea
Quota exceeded for resources: ['rbac_policy'].
~~~


Version-Release number of selected component (if applicable):
OSP 10

How reproducible:
All the time

Actual results:
Non meaningful error.

Expected results:
The same error message as the neutron cli returns

Additional info:
Acknowledged that the we are still in a transition state to the openstack cli.
https://docs.openstack.org/developer/python-neutronclient/devref/transition_to_osc.html

Comment 3 Julie Pichon 2018-01-25 13:22:26 UTC
Unfortunately, "fixing all the error messages" is a bit too vague and difficult to resolve, it is better to open a bug about a specific message in order to get it fixed (cf. also https://bugs.launchpad.net/python-openstackclient/+bug/1554302 ).

It appears the one mentioned in the description is now resolved (and likely applies to all the 'network' commands):

$ openstack network rbac create --action access_as_external --target-project 6210656262954848a7ff0fc27a7e0201 --type network ed5848fd-8f1d-4d1e-b842-61b9ee7cfbfa
HttpException: Conflict (HTTP 409) (Request-ID: req-8f5ef45f-7259-4927-abae-efb48e1071ff), Quota exceeded for resources: ['rbac_policy'].

Based on this I'm going to mark this one as resolved, though please feel free to open more targeted bugs as you find new problematic messages.

Comment 10 errata-xmlrpc 2018-06-27 13:31:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.