Bug 1459341 - Atomic Host images omit many common locales that all other flavors include
Atomic Host images omit many common locales that all other flavors include
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: rpm-ostree (Show other bugs)
26
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Colin Walters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-06 17:05 EDT by Adam Williamson
Modified: 2017-06-06 18:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-06 18:11:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2017-06-06 17:05:41 EDT
Apparently, it was decided that Fedora Atomic Host images should include only the locales 'officially supported' by RHEL 7 - see https://bugzilla.redhat.com/show_bug.cgi?id=1430182 , jlebon says it was decided to apply the same choice to Fedora as to RHEL.

This is entirely out of step with all other Fedora flavors, though, I believe. These include far, far more locales. The 'RHEL supported' list doesn't include such obvious and widely-used locales as en_CA and en_AU. I'm not sure it makes sense to just decide the RHEL 'supported locales' list is an appropriate basis for the list of locales to include in Fedora images.

(not sure which component is best for this, picking rpm-ostree to get the appropriate people's attention).
Comment 1 Matthew Miller 2017-06-06 17:29:49 EDT
Hmmmm. We did something similar with the cloud image, but in that case, it was fairly easy to add back. Also, that was based on size not RHEL parity.

> (not sure which component is best for this, picking rpm-ostree to get the appropriate people's attention).

Probably https://pagure.io/atomic-wg/issues since it's a policy decision and since it's general rather than a specific component.
Comment 2 Colin Walters 2017-06-06 17:35:12 EDT
Yeah, I'd say we should track this as a WG issue indeed.
Comment 3 Adam Williamson 2017-06-06 18:11:56 EDT
https://pagure.io/atomic-wg/issue/282

Note You need to log in before you can comment on or make changes to this bug.