Bug 1459354 - Metrics and Logging Broken When Using Docker for Mac Community Edition
Metrics and Logging Broken When Using Docker for Mac Community Edition
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
3.5.0
Unspecified Mac OS
low Severity low
: ---
: ---
Assigned To: Cesar Wong
Xingxing Xia
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-06 18:20 EDT by Nick Schuetz
Modified: 2017-10-09 10:56 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-09 10:56:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Schuetz 2017-06-06 18:20:37 EDT
Description of problem:
When trying to deploy OpenShift using 'oc cluster up --metrics --logging' on a Mac using Docker Community Edition 17.03.1-ce-mac12 metrics and logging fail to deploy because of an error parsing the docker version number.

Version-Release number of selected component (if applicable):
oc v3.5.5.15
Docker for Mac Community Edition Version 17.03.1-ce-mac12 (17661)

How reproducible:
Always

Steps to Reproduce:
1. Download OCP version of oc
2. Run: oc cluster up --metrics --logging
3. Go into both the logging and openshift-infra projects and do a describe on the deployer pods.

Actual results:

 7m		14s		36	{kubelet 192.168.65.2}			Warning		FailedSync	Error syncing pod, skipping: failed to "StartContainer" for "POD" with RunContainerError: "runContainer: docker: failed to parse docker version \"17.03.1-ce\": illegal zero-prefixed version component \"03\" in \"17.03.1-ce\""

Expected results:

Logging and Metrics should both deploy successfully without problems parsing the docker version.

Additional info:
Comment 1 Cesar Wong 2017-08-25 11:47:29 EDT
The issue with parsing the CE version number should have been fixed in the v3.6 OCP client.

The CE version of Docker is not supported with OCP <= 3.5. If you want/need to use the v3.5.x client, you can downgrade Docker to v1.13.1:
https://download.docker.com/mac/stable/1.13.1.15353/Docker.dmg
Comment 2 Cesar Wong 2017-10-09 10:56:23 EDT
Closing this issue due to age. Current oc client works with Docker CE.

Note You need to log in before you can comment on or make changes to this bug.