Bug 145937 - rc.sysinit assumes usb-core is built-in
rc.sysinit assumes usb-core is built-in
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-24 04:17 EST by Jon Smirl
Modified: 2014-03-16 22:52 EDT (History)
1 user (show)

See Also:
Fixed In Version: 8.05-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-03 16:25:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Smirl 2005-01-24 04:17:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem, from rc.sysinit:
# Mount /proc and /sys (done here so volume labels can work with fsck)
mount -n -t proc /proc /proc
[ -d /proc/bus/usb ] && mount -n -t usbfs /proc/bus/usb /proc/bus/usb

This assumes the mount point /proc/bus/usb is there. If it is not
there usbfs won't be mounted and bad things happen later. For example
kudzu loses all your USB devices.

In RH kernels the mount point is always there since usb-core is always
built-in in order to support boot from USB file systems. If you are
not booting from a USB file system usb-core works fine as a module.
rc.sysinit needs to make sure this module is loaded before trying to
mount usbfs.
Comment 1 Bill Nottingham 2005-01-25 01:06:21 EST
This is just adding redundant modprobe calls that will only slow down
the default case (albeit not much); that's not really a *good* solution.
Comment 2 Jon Smirl 2005-01-25 12:17:12 EST
There is already a test to see if the directory is there. Only do the
mod probe if it is missing.
Comment 3 Bill Nottingham 2005-01-25 12:32:47 EST
Actually....

usb-core will get loaded if the host controller is loaded, right?

So, what's needed is to simply add a dev.d entry for usbcore that
mounts usbfs.
Comment 4 Jon Smirl 2005-01-25 20:39:51 EST
Another way is for the installer to add a line to fstab. All of these
are minor fixes for the problem once you figure out what is going on.

The problem here is that doing something simple like making usb-core a
module causes a hard to diagnose failure in FC3. A root part of this
is from kudzu using /proc/bus/xxx instead of /sys
Comment 5 Bill Nottingham 2005-10-03 16:25:36 EDT
This was fixed in a later build.

Note You need to log in before you can comment on or make changes to this bug.