Bug 145939 - Logitech bluetooth mouse needs some more scripts and services run
Logitech bluetooth mouse needs some more scripts and services run
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bluez-utils (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Woodhouse
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-24 04:56 EST by Christian Schaller
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.15-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-09 13:01:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Schaller 2005-01-24 04:56:50 EST
I just bought a Logitech Bluetooth mouse (Mx900) which use bluetooth
for its wireless service and the mouse batterycharger also functions
as a bluetooth hub. However to make this mouse work on my Fedora
install having the 'Bluetooth services' enabled is not enough. I have
to run the command 'hid2hci' and 'hidd --server' before the mouse
starts working.

I discussed the issue briefly with Edd Dumbill of gnome-bluetooth and
xml fame. He said that the two command above where run automatically
on a Debian system and that there wasn't really much of a reason not
to do so as it maximized making things 'just work'.

I hope the Red Hat/Fedora bluetooth service can be updated to do this
automatically too.
Comment 1 David Woodhouse 2005-01-24 06:08:32 EST
echo HID2HCI_ENABLE=true >> /etc/sysconfig/bluetooth
echo HIDDARGS=\"--server --search\" >> /etc/sysconfig/hidd
/sbin/chkconfig --level 345 hidd on

If that doesn't work, tell me about the failure.

If it does, then I suppose the best thing to do is refile a bug
against kudzu or the installer. Or suggest better ways that I could
autodetect the need to do these things.
Comment 2 Christian Schaller 2005-01-25 04:15:41 EST
Ok, I tested a lot around this now and here is what I found.

HIDHCI_ENABLE was already set to TRUE.

For HIDDARGS I noticed something peculiar. If I just use the --server
option things work fine. But if I have the --search option added then
a few things happen. First of all I think the hidd process dies at
some point as I am not able to stop the hidd service without getting
failed when it is on. Secondly it do seem to do something with my
mouse as it basically stops working until I take out the batteries
from it to reset it. But as I said, just having '--server' as the
option makes everything work fine.
Comment 3 David Woodhouse 2005-01-25 15:27:21 EST
It looks like '--server --search' was wrong; sorry. Those are mutually
exclusive options. As you observed, you only want '--server'. I'll fix
the shipped config file.
Comment 4 Daniel Roesen 2005-06-04 17:53:53 EDT
When looking at #157971 comment 15, I think there's still the problem that
hidd startup script isn't linked to any runlevels in FC4T3, and chkconfig
--add is manually needed...
Comment 5 David Woodhouse 2005-08-09 13:00:24 EDT
I don't think we should necessarily be running hidd by default in all cases. The
installed should probably enable it only if it's needed. The installer needs to
learn about Bluetooth keyboard/mouse anyway.

Note You need to log in before you can comment on or make changes to this bug.