Bug 145940 - ypbind init script broken in Raw Hide
Summary: ypbind init script broken in Raw Hide
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ypbind   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-24 10:14 UTC by Joe Orton
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version: 1.17.2-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-05 01:13:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Orton 2005-01-24 10:14:55 UTC
"initlog" has been removed in the Raw Hide initscripts, and the ypbind
init script doesn't work any more:

[root@trash ~]# rpm -q ypbind initscripts
ypbind-1.17.2-3
initscripts-8.04-1
[root@trash ~]# service ypbind start
Binding to the NIS domain:
Listening for an NIS domain server./etc/init.d/ypbind: line 55:
initlog: command not found

Comment 1 Steve Dickson 2005-01-24 11:29:41 UTC
What (if anything) should be used in its place?

Comment 2 Joe Orton 2005-01-24 11:55:29 UTC
Just "if" and "echo" would be sufficient as far as I know.

http://www.redhat.com/archives/fedora-devel-list/2005-January/msg00065.html


Comment 3 Steve Dickson 2005-01-24 14:22:38 UTC
This is fixed in ypbind-1.17.2-5 which is on the devel 
tree and is built under dist-fc4. Now I did check in the
fix to the FC-3 tree, but its not clear (since this is a 
bug for rawhide) whether I should go a head a build 
a new FC3 rpm.... 

Comment 4 Joe Orton 2005-01-24 14:26:31 UTC
Thanks Steve.  I think we can safely assume that /sbin/initlog will
not disappear in an FC3 initscript update so it's not necessary to
make the change for the FC3 ypbind, no.

Comment 5 Bill Nottingham 2005-01-25 06:07:48 UTC
Correct, initlog is only gone in FC4.


Note You need to log in before you can comment on or make changes to this bug.