This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1459401 - Setting up bilingual keyboards results in lower case space bar duplicating super+space -- Can't enter space char without using shift key
Setting up bilingual keyboards results in lower case space bar duplicating su...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
26
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-06 23:55 EDT by Leslie Satenstein
Modified: 2017-07-03 08:53 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-03 08:53:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leslie Satenstein 2017-06-06 23:55:08 EDT
Description of problem:

I use the Canadian French keyboard (my default) layout and the US keyboard layout.

If with anaconda (F26 beta 1-4) I add the Canadian French, I make the USA keyboard second in the list, then on reboot,
the lower case space bar acts as Super+space.

With alt or shift key, the space bar emits a space character



Version-Release number of selected component (if applicable):


How reproducible:

with live and network install versions.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

space bar emits a space character


Additional info:

If I leave anaconda to the default (US) and leave my keyboard setup to post installation and boot, the keyboard (US / ca ) layouts work as expected.

Since I have work around, I consider this bug as lower priority.
Comment 1 Leslie Satenstein 2017-06-13 19:01:46 EDT
Given the June 13, beta1-4, followed by a dnf distro-sync
This bug continues to be present.

Since there are many countries which have bilingual keyboards, this bug is going to be a major annoyance.
Comment 2 Leslie Satenstein 2017-06-25 11:57:56 EDT
Originally filed as Fedora 26, Do not know how it was changed to Fedora 24.

If I add a keyboard layout in the anaconda spoke (now two layouts),
on booting Fedora26, I can't enter the space character.

I have to use the shift key to do so.

The space bar has been mapped to super+space, which is layout select.


The release note needs to be updated if this is not fixed before golive.

My workaround is to not modify the anaconda keyboard spoke setting, and after the reboot, I setup the keyboards.

That works for me, (I am English R/W/Speak), but does not work for other users from other languages.
Comment 3 Leslie Satenstein 2017-07-03 08:53:43 EDT
I loaded a compose of 2 July 2017.

It does not have the same anaconda version (no nag screen)
With this version, there is no issue.

I presume that as the compose of 2 July will be the F26 golive
this bug can be closed, as the problem has disappeared

Note You need to log in before you can comment on or make changes to this bug.