Bug 1459402 - brick process crashes while running bug-1432542-mpx-restart-crash.t in a loop
brick process crashes while running bug-1432542-mpx-restart-crash.t in a loop
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
mainline
x86_64 All
urgent Severity urgent
: ---
: ---
Assigned To: Mohit Agrawal
brick-multiplexing
:
Depends On: 1459400
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-06 23:55 EDT by Mohit Agrawal
Modified: 2017-09-05 13:33 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.12.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1459400
Environment:
Last Closed: 2017-09-05 13:33:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Worker Ant 2017-06-07 00:00:19 EDT
REVIEW: https://review.gluster.org/17471 (glusterfsd: Sometime brick process is crashed after enable brick mux) posted (#4) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)
Comment 2 Worker Ant 2017-06-07 11:42:18 EDT
COMMIT: https://review.gluster.org/17471 committed in master by Jeff Darcy (jeff@pl.atyp.us) 
------
commit 0a07cffbf363e35e9617e5d4ef605f26ede06f05
Author: Mohit Agrawal <moagrawa@redhat.com>
Date:   Tue Jun 6 13:44:06 2017 +0530

    glusterfsd: Sometime brick process is crashed after enable brick mux
    
    Problem: glusterfsd is getting Segfault while running bug-1432542-mpx-restart-crash.t
             in a loop in while brick mux is enabled.
    
    Solution: Change the index_worker code as well as notify code in index.c
              to cleanup index_worker thread appropriately.
    
    BUG: 1459402
    Change-Id: Id036664dc34309dd3f6e54746fc2724182cb074f
    Signed-off-by: Mohit Agrawal <moagrawa@redhat.com>
    Reviewed-on: https://review.gluster.org/17471
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jeff@pl.atyp.us>
Comment 3 Shyamsundar 2017-09-05 13:33:02 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.