Bug 1459446 - backport msg: use last_tlv if there is not enough room for another tlv
backport msg: use last_tlv if there is not enough room for another tlv
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: linuxptp (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Miroslav Lichvar
Qiao Zhao
:
Depends On:
Blocks: 1371853
  Show dependency treegraph
 
Reported: 2017-06-07 04:00 EDT by Hangbin Liu
Modified: 2018-04-10 13:33 EDT (History)
2 users (show)

See Also:
Fixed In Version: linuxptp-1.8-5.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 13:32:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:0939 None None None 2018-04-10 13:33 EDT

  None (edit)
Description Hangbin Liu 2017-06-07 04:00:13 EDT
Description of problem:
During Management SET message fuzz test, pmc crashed due to not check the latest tlv length. Please backport commit to fix this issue.

commit 43b2f5d1207a010f1df67e101b129b09502371e2
Author: Hangbin Liu <liuhangbin@gmail.com>
Date:   Fri May 12 15:36:45 2017 +0800

    msg: use last_tlv if there is not enough room for another tlv
Comment 1 Qiao Zhao 2017-07-25 08:39:32 EDT
Hi developer,

Could you give some detail information about how to test/verify this bug?
I have no idea for this.

--
Thanks,
Qiao
Comment 9 errata-xmlrpc 2018-04-10 13:32:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0939

Note You need to log in before you can comment on or make changes to this bug.