Bug 145949 - Stack traces: no practical way to get them to Redhat
Stack traces: no practical way to get them to Redhat
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-24 06:28 EST by Graham Leggett
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 22:33:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham Leggett 2005-01-24 06:28:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.7.5) Gecko/20041107 Firefox/1.0

Description of problem:
When a crash occurs in the anaconda installer, a stack trace is
printed to the screen. This is useless to the end user, as it cannot
be cut and pasted and submitted to bugzilla.

An option is given to save the stack trace to a floppy disk, but as
it's 2005 and nobody used floppy disks any more this option to longer
works.

What should happen is that the stack trace be delivered over the
internet direct to bugzilla via email, querying the user for an
alternate MTA if necessary to do so.

Adding this will mean that the highly unreliable anaconda installer
will have its first shot at being meaningfully stable.


Version-Release number of selected component (if applicable):
Fedora Core 3 disk 1

How reproducible:
Always

Steps to Reproduce:
xxx

Additional info:
Comment 1 Chris Lumens 2005-01-24 13:56:29 EST
When a stack trace occurs, the complete text of the trace (and all sorts of
other information) may be found in /tmp/anacdump.txt on the system you are
trying to install onto.  You can switch over to a console with ctrl-alt-f2 and
use scp to transfer the dump to another machine.  From there, you can use a web
browser or do whatever else to get the stack trace to us.
Comment 2 Graham Leggett 2005-01-24 16:42:27 EST
And the user is supposed to know this how?

The crash screen needs to be updated to tell the user

a) that the backtrace can be found in this file; and
b) that a network connection is actually present to do the transfer; and
c) what tools are available to them to achieve this

Do not assume that the user knows what the anaconda author knows. Unless you
tell the user these things, there is no way they can be expected to know. The
very high failure rate of anaconda shows clearly that the bug reports are not
getting through to Redhat. Marking this as "not a bug" does not improve the user
experience, please fix this before marking this bug as closed.

Note You need to log in before you can comment on or make changes to this bug.