Bug 1459507 - [abrt] fabric: expected an indented block (fabfile.py, line 45)
[abrt] fabric: expected an indented block (fabfile.py, line 45)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fabric (Show other bugs)
25
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Athmane Madjoudj
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:6f615e427ffdaddfd791f05b6fb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-07 06:21 EDT by bitchecker
Modified: 2017-07-29 13:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-29 13:49:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (521 bytes, text/plain)
2017-06-07 06:21 EDT, bitchecker
no flags Details
File: environ (3.62 KB, text/plain)
2017-06-07 06:21 EDT, bitchecker
no flags Details

  None (edit)
Description bitchecker 2017-06-07 06:21:24 EDT
Version-Release number of selected component:
fabric-1.12.1-0.fc25

Additional info:
reporter:       libreport-2.8.0
cmdline:        /usr/bin/python2 /usr/bin/fab -R cliente1 monitor
executable:     /usr/bin/fab
kernel:         4.11.3-200.fc25.x86_64
pkg_fingerprint: 4089 D8F2 FDB1 9C98
pkg_vendor:     Fedora Project
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
expected an indented block (fabfile.py, line 45)

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/fabric/main.py", line 666, in main
    docstring, callables, default = load_fabfile(fabfile)
  File "/usr/lib/python2.7/site-packages/fabric/main.py", line 167, in load_fabfile
    imported = importer(os.path.splitext(fabfile)[0])
  File "/media/Multimedia/Programmazione/PYTHON/software/monitoring/fabfile.py", line 45
    with cd("/tmp"):
       ^
IndentationError: expected an indented block
Comment 1 bitchecker 2017-06-07 06:21:30 EDT
Created attachment 1285742 [details]
File: backtrace
Comment 2 bitchecker 2017-06-07 06:21:32 EDT
Created attachment 1285743 [details]
File: environ
Comment 3 Athmane Madjoudj 2017-07-29 13:49:55 EDT
It seems to be error in the script (syntax / runtime / etc...)
Closing for now, if you think that it a real bug, please attach a reproducible code snippet.

Note You need to log in before you can comment on or make changes to this bug.