Bug 1459530 - [RFE] Need a way to resolve gfid split brains
Summary: [RFE] Need a way to resolve gfid split brains
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
Assignee: Karthik U S
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1413959 1531934
TreeView+ depends on / blocked
 
Reported: 2017-06-07 12:03 UTC by Karthik U S
Modified: 2018-01-06 18:28 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.12.0
Doc Type: Enhancement
Doc Text:
Clone Of: 1413959
Environment:
Last Closed: 2017-08-23 10:08:43 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2017-06-07 12:05:58 UTC
REVIEW: https://review.gluster.org/17485 (cluster/afr: GFID split-brain resolution with exiting CLI) posted (#1) for review on master by Karthik U S (ksubrahm@redhat.com)

Comment 2 Worker Ant 2017-06-07 12:08:18 UTC
REVIEW: https://review.gluster.org/17485 (cluster/afr: GFID split-brain resolution with existing CLI) posted (#2) for review on master by Karthik U S (ksubrahm@redhat.com)

Comment 3 Worker Ant 2017-06-14 12:39:54 UTC
REVIEW: https://review.gluster.org/17485 (cluster/afr: GFID split-brain resolution with existing CLI) posted (#3) for review on master by Karthik U S (ksubrahm@redhat.com)

Comment 4 Worker Ant 2017-07-04 12:54:32 UTC
REVIEW: https://review.gluster.org/17485 (cluster/afr: GFID split-brain resolution with existing CLI) posted (#4) for review on master by Karthik U S (ksubrahm@redhat.com)

Comment 5 Worker Ant 2017-07-12 12:07:25 UTC
REVIEW: https://review.gluster.org/17485 (cluster/afr: GFID split-brain resolution with existing CLI) posted (#5) for review on master by Karthik U S (ksubrahm@redhat.com)

Comment 6 Worker Ant 2017-07-12 13:08:11 UTC
REVIEW: https://review.gluster.org/17485 (cluster/afr: GFID split-brain resolution with existing CLI) posted (#6) for review on master by Karthik U S (ksubrahm@redhat.com)

Comment 7 Worker Ant 2017-07-13 13:08:23 UTC
REVIEW: https://review.gluster.org/17485 (cluster/afr: GFID split-brain resolution with existing CLI) posted (#7) for review on master by Karthik U S (ksubrahm@redhat.com)

Comment 8 Worker Ant 2017-07-14 07:30:51 UTC
REVIEW: https://review.gluster.org/17485 (cluster/afr: GFID split-brain resolution with existing CLI) posted (#8) for review on master by Karthik U S (ksubrahm@redhat.com)

Comment 9 Worker Ant 2017-07-17 07:10:15 UTC
REVIEW: https://review.gluster.org/17485 (cluster/afr: GFID split-brain resolution with existing CLI) posted (#9) for review on master by Karthik U S (ksubrahm@redhat.com)

Comment 10 Worker Ant 2017-07-17 07:41:23 UTC
REVIEW: https://review.gluster.org/17485 (cluster/afr: GFID split-brain resolution with existing CLI) posted (#10) for review on master by Karthik U S (ksubrahm@redhat.com)

Comment 11 Worker Ant 2017-07-17 12:14:44 UTC
REVIEW: https://review.gluster.org/17485 (cluster/afr: GFID split-brain resolution with existing CLI) posted (#11) for review on master by Karthik U S (ksubrahm@redhat.com)

Comment 12 Worker Ant 2017-07-17 12:25:20 UTC
REVIEW: https://review.gluster.org/17485 (cluster/afr: GFID split-brain resolution with existing CLI) posted (#12) for review on master by Karthik U S (ksubrahm@redhat.com)

Comment 13 Worker Ant 2017-07-18 06:21:27 UTC
REVIEW: https://review.gluster.org/17485 (cluster/afr: GFID split-brain resolution with existing CLI) posted (#13) for review on master by Karthik U S (ksubrahm@redhat.com)

Comment 14 Worker Ant 2017-07-18 15:24:58 UTC
COMMIT: https://review.gluster.org/17485 committed in master by Jeff Darcy (jeff@pl.atyp.us) 
------
commit 657d78dbad118e511e1fca8b1badb9f8ae7a6f60
Author: karthik-us <ksubrahm@redhat.com>
Date:   Wed Jun 7 15:56:13 2017 +0530

    cluster/afr: GFID split-brain resolution with existing CLI
    
    Problem:
    Currently there is no way for the admin from CLI to resolve gfid
    split-brain based on some policy like choice of the brick, mtime
    or size.
    
    Fix:
    With the existing CLI options based on size, mtime, and choice of
    brick, we do lookup on the parent for the specified file. As
    part of the lookup, if we find gfid mismatch, we resolve them
    based on the policy and return. If the file is not in gfid split-
    brain, then we check for the data and metadata split-brain in the
    getxattr code path, and resolve if any.
    
    This will work provided absolute path to the file with the CLI
    and not with gfid of the file. Hence the source-brick policy
    without any file path will also not resolve the gfid split-brain
    since it uses the gfid of the files. But it can resolve any other
    type of split-brains and skip the gfid mismatch resolution with
    the usual error message.
    
    Reverting the change https://review.gluster.org/17290. This patch
    resolves the issue.
    
    Fixes gluster/glusterfs#135
    
    Change-Id: Iaeba6fc32f184a34255d03be87cda02773130a09
    BUG: 1459530
    Signed-off-by: karthik-us <ksubrahm@redhat.com>
    Reviewed-on: https://review.gluster.org/17485
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>

Comment 15 Shyamsundar 2017-09-05 17:33:35 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.