Bug 1459570 - [RFE] allow errata search by providing id or CVE only
[RFE] allow errata search by providing id or CVE only
Status: NEW
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Errata Management (Show other bugs)
6.2.10
x86_64 Linux
medium Severity low (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-07 09:26 EDT by Pavel Moravec
Modified: 2017-12-05 02:24 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Moravec 2017-06-07 09:26:00 EDT
Description of problem:
When searching for an errata and knowing its id (say RHSA-2017:1382) or CVE (here CVE-2017-7502), one has to use filter

id = RHSA-2017:1382
or
cve = CVE-2017-7502

It would be user more-friendly if one can search by providing just the id or CVE, i.e.:

RHSA-2017:1382
or
CVE-2017-7502

(This does not work atm)


Version-Release number of selected component (if applicable):
Satellite 6.2.9


How reproducible:
100%


Steps to Reproduce:
1. Go to Content -> Errata page
2. Click to an errata to know its id and cve
3. Try to search for that errata by just providing the id or the cve to the Search field.


Actual results:
3. returns nothing.


Expected results:
3. to return the expected errata.


Additional info:
Similar functionality works well in searching Hosts.

Note You need to log in before you can comment on or make changes to this bug.