Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1459588 - With OpenStack and OpenShift on the same host we have OVS conflicts
With OpenStack and OpenShift on the same host we have OVS conflicts
Status: CLOSED WONTFIX
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.5.1
All Linux
low Severity medium
: ---
: 3.10.0
Assigned To: Scott Dodson
Johnny Liu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-07 10:17 EDT by Sebastian Jug
Modified: 2018-04-16 10:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-16 10:50:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sebastian Jug 2017-06-07 10:17:47 EDT
Description of problem:
When we have a baremetal node managed by OpenStack, it uses OVS for networking. Installing OpenShift seems to work to some degree, however uninstallation of OCP on this host will introduce breaking change with stopping/uninstalling Open vSwitch.


Version-Release number of selected component (if applicable):
Running against 3.5 when discovered using openshift-ansible, still an issue in current versions as well.


How reproducible:
Every time we uninstall OCP on a OpenStack managed baremetal node.


Steps to Reproduce:
1. Have OpenStack managed cluster of baremetal nodes that are using OVS (as default) networking.
2. Install OpenShift on baremetal nodes
3. Uninstall OpenShift

Actual results:
Baremetal node drops due to OVS tasks in uninstall playbook.

Expected results:
OpenStack and OpenShift should be able to coexist.
Comment 1 Scott Dodson 2017-06-07 11:20:24 EDT
Are you disabling the openshift SDN? If we simply made the installer not remove openvswitch when you've disabled the openshift sdn would that suffice?
Comment 2 Sebastian Jug 2017-06-07 12:29:24 EDT
The problem is that they use the same service, so stopping the service brings down both.
Comment 3 Scott Dodson 2017-06-07 13:20:38 EDT
Ok, so if we just do nothing with openvswitch whenever openshift_use_openshift_sdn=false will that solve your problem?
Comment 4 Sebastian Jug 2017-07-13 15:19:13 EDT
We still do use the openshift sdn on top of openstack, so we are not disabling it.

Note You need to log in before you can comment on or make changes to this bug.