Bug 1459615 - debhelper-10.2.5-3.fc27 FTBFS in rawhide
debhelper-10.2.5-3.fc27 FTBFS in rawhide
Status: CLOSED DUPLICATE of bug 1134914
Product: Fedora
Classification: Fedora
Component: debhelper (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Oron Peled
Fedora Extras Quality Assurance
https://koji.fedoraproject.org/koji/t...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-07 11:10 EDT by Jitka Plesnikova
Modified: 2017-06-07 13:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-07 13:22:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jitka Plesnikova 2017-06-07 11:10:25 EDT
debhelper-10.2.5-3.fc27 failed to build during Perl 5.26 mass rebuild.

dpkg-architecture: warning: unknown CC system type ppc64le-redhat-linux, falling back to default (native compilation)
dpkg-architecture: warning: unknown CC system type ppc64le-redhat-linux, falling back to default (native compilation)
dpkg-architecture: warning: unknown CC system type ppc64le-redhat-linux, falling back to default (native compilation)
dpkg-architecture: warning: unknown CC system type ppc64le-redhat-linux, falling back to default (native compilation)
dpkg-architecture: warning: unknown CC system type ppc64le-redhat-linux, falling back to default (native compilation)
dpkg-architecture: warning: unknown CC system type ppc64le-redhat-linux, falling back to default (native compilation)
dpkg-architecture: warning: unknown CC system type ppc64le-redhat-linux, falling back to default (native compilation)
dpkg-architecture: warning: unknown CC system type ppc64le-redhat-linux, falling back to default (native compilation)
#   Failed test 'DEB_BUILD_OPTIONS=parallel=5 with --parallel'
#   at t/buildsystems/buildsystem_tests.t line 573.
#     Structures begin differing at:
#          $got->[0] = 'dpkg-architecture: warning: unknown CC system type ppc64le-redhat-linux, falling back to default (native compilation)'
#     $expected->[0] = Does not exist
#   Failed test 'DEB_BUILD_OPTIONS=parallel=5 with --max-parallel=2'
#   at t/buildsystems/buildsystem_tests.t line 573.
#     Structures begin differing at:
#          $got->[0] = 'dpkg-architecture: warning: unknown CC system type ppc64le-redhat-linux, falling back to default (native compilation)'
#     $expected->[0] = Does not exist
#   Failed test 'DEB_BUILD_OPTIONS=parallel=5: no make warnings about unavail parent jobserver'
#   at t/buildsystems/buildsystem_tests.t line 573.
#     Structures begin differing at:
#          $got->[0] = 'dpkg-architecture: warning: unknown CC system type ppc64le-redhat-linux, falling back to default (native compilation)'
#     $expected->[0] = Does not exist
t/buildsystems/buildsystem_tests.t .. 
Dubious, test returned 3 (wstat 768, 0x300)
Failed 3/300 subtests 
# Looks like you failed 3 tests of 300.
t/dh_installdocs/dh_installdocs.t ... ok
t/dh_installinit/dh_installinit.t ... ok
Test Summary Report
-------------------
t/buildsystems/buildsystem_tests.t (Wstat: 768 Tests: 300 Failed: 3)
  Failed tests:  289, 291, 295
  Non-zero exit status: 3
Files=12, Tests=626, 16 wallclock secs ( 0.10 usr  0.01 sys +  7.62 cusr  1.63 csys =  9.36 CPU)
Result: FAIL
Failed 1/12 test programs. 3/626 subtests failed.
Comment 1 Sergio Monteiro Basto 2017-06-07 13:22:02 EDT
is a similar problem of bug #1134914

from build.log
+ dpkg-architecture -qDEB_BUILD_GNU_TYPE
powerpc64le-linux-gnu
+ dpkg-architecture -qDEB_HOST_GNU_TYPE
dpkg-architecture: warning: unknown CC system type ppc64le-redhat-linux, falling back to default (native compilation)
powerpc64le-linux-gnu


running `pkg-architecture -qDEB_HOST_GNU_TYPE` , should not send warning ...

mark as duplicated

*** This bug has been marked as a duplicate of bug 1134914 ***

Note You need to log in before you can comment on or make changes to this bug.