This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1459622 - Incredibly slow boot (blaming kdump)
Incredibly slow boot (blaming kdump)
Status: CLOSED DUPLICATE of bug 1447512
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kexec-tools (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: kdump team
Qiao Zhao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-07 11:32 EDT by Matěj Cepl
Modified: 2017-06-30 00:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-30 00:20:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport report (16.35 MB, application/x-xz)
2017-06-07 11:32 EDT, Matěj Cepl
no flags Details
content of /var/log plus output of journalctl -xb and dmesg (11.94 MB, application/zip)
2017-06-07 11:33 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2017-06-07 11:32:19 EDT
Created attachment 1285832 [details]
sosreport report

Description of problem:
When I boot up my machine (Lenovo Thinkpad T440s, 11GB RAM, 2x2CPU) it takes certainly more than minute to get through boot process.

This is the output of systemd-analyze blame|head -n 20:

mitmanek:~# systemd-analyze blame|head -n20
         24.441s kdump.service
         14.782s systemd-cryptsetup@swap.service
         11.091s systemd-cryptsetup@home.service
          6.018s NetworkManager-wait-online.service
          5.632s lvm2-pvscan@8:5.service
          5.480s lvm2-pvscan@8:2.service
          4.424s plymouth-quit-wait.service
          2.760s dnf-makecache.service
          2.100s docker.service
          1.392s systemd-udev-settle.service
           853ms postfix.service
           702ms udisks2.service
           448ms tuned.service
           435ms firewalld.service
           433ms network.service
           409ms dev-mapper-rhel\x2droot.device
           369ms lvm2-monitor.service
           340ms docker-storage-setup.service
           285ms libvirtd.service
           272ms polkit.service
mitmanek:~#

Version-Release number of selected component (if applicable):
kernel-3.10.0-673.el7.x86_64
kernel-3.10.0-675.el7.x86_64
kernel-3.10.0-677.el7.x86_64
lvm2-2.02.171-3.el7.x86_64
systemd-219-40.el7.x86_64
kexec-tools-2.0.14-12.el7.x86_64

How reproducible:
It has been happening for quite some time on RHEL-7.4/Nightlies.
Comment 2 Matěj Cepl 2017-06-07 11:33 EDT
Created attachment 1285833 [details]
content of /var/log plus output of journalctl -xb and dmesg
Comment 3 Xunlei Pang 2017-06-30 00:20:12 EDT
This should happen only for the first boot when no initramfs exists and gets built out.

There was a BZ tracking this: BZ1447512

*** This bug has been marked as a duplicate of bug 1447512 ***

Note You need to log in before you can comment on or make changes to this bug.