Bug 1459642 - Duplicated entries of users and groups in lxqt-admin-user
Duplicated entries of users and groups in lxqt-admin-user
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lxqt-admin (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Raphael Groner
Fedora Extras Quality Assurance
https://github.com/lxde/lxqt/issues/1308
: Patch, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-07 13:05 EDT by Jia Yuan Lo
Modified: 2017-06-19 21:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: lxqt-admin-0.11.1-5.fc26 lxqt-admin-0.11.1-5.fc24 lxqt-admin-0.11.1-5.fc25
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-16 09:18:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot 1 (778.57 KB, image/png)
2017-06-07 13:05 EDT, Jia Yuan Lo
no flags Details
[PATCH] lxqt-admin-user: Check for duplicates from getgrent, getpwent (299.84 KB, patch)
2017-06-09 04:49 EDT, Raphael Groner
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Debian BTS 32370 None None None 2017-06-09 04:55 EDT

  None (edit)
Description Jia Yuan Lo 2017-06-07 13:05:27 EDT
Created attachment 1285856 [details]
Screenshot 1

Description of problem:
Thought to have connections to SDDM
https://bugzilla.redhat.com/show_bug.cgi?id=1445705

But seems UNLIKELY as KDE also hit by that
https://bugzilla.redhat.com/show_bug.cgi?id=1446782

Anyway, please check the attached screenshot, it clearly shows the same users twice. The groups also shown twice if one go verify now.

How reproducible:
Launch lxqt-admin-user from a live image and/or after installation

Additional info:
/etc/groups seems normal (if it is used at all?)

Removing one entry, removes both entries in lxqt-admin-user

Haven't tested out adding.
Comment 1 Raphael Groner 2017-06-07 13:23:51 EDT
It's doubtful to see any relation to sddm or KDE in general.

IMHO the method UserManager::loadUsersAndGroups() is b0rken due to there's no check implemented for duplications:
https://github.com/lxde/lxqt-admin/blob/master/lxqt-admin-user/usermanager.cpp#L55

Do you have any users in several groups? What happens if you create a new user as membor of just one group?
Comment 2 Raphael Groner 2017-06-07 13:30:58 EDT
(In reply to Jia Yuan Lo from comment #0)
> Created attachment 1285856 [details]
> Screenshot 1

Okay, every user is listed twice. That might be because each user found from /etc/passwd by getgrent() gets added a second time [1] to the collected lists of groups and members generated from getgrent(), nevertheless what getgrent() [2] reports.

It seems worth to report this to upstream.
 
[1] https://github.com/lxde/lxqt-admin/blob/master/lxqt-admin-user/usermanager.cpp#L78
[2] https://github.com/lxde/lxqt-admin/blob/master/lxqt-admin-user/usermanager.cpp#L65
Comment 3 Jia Yuan Lo 2017-06-08 02:37:56 EDT
Reported upstream: https://github.com/lxde/lxqt/issues/1308
Comment 4 Raphael Groner 2017-06-08 14:35:28 EDT
Thanks.
Comment 5 Raphael Groner 2017-06-09 04:47:33 EDT
Upstream has a patch, please apply.
https://github.com/lxde/lxqt-admin/pull/47
Comment 6 Raphael Groner 2017-06-09 04:49 EDT
Created attachment 1286341 [details]
[PATCH] lxqt-admin-user: Check for duplicates from getgrent, getpwent
Comment 7 Fedora Update System 2017-06-10 14:30:09 EDT
lxqt-admin-0.11.1-5.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-c84af76d19
Comment 8 Fedora Update System 2017-06-10 14:30:19 EDT
lxqt-admin-0.11.1-5.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-e27250dafa
Comment 9 Fedora Update System 2017-06-10 14:30:24 EDT
lxqt-admin-0.11.1-5.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f20a0e6e4c
Comment 10 Fedora Update System 2017-06-12 00:39:36 EDT
lxqt-admin-0.11.1-5.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f20a0e6e4c
Comment 11 Fedora Update System 2017-06-12 02:32:04 EDT
lxqt-admin-0.11.1-5.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-c84af76d19
Comment 12 Fedora Update System 2017-06-12 02:32:28 EDT
lxqt-admin-0.11.1-5.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-e27250dafa
Comment 13 Fedora Update System 2017-06-16 09:18:03 EDT
lxqt-admin-0.11.1-5.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2017-06-19 20:47:32 EDT
lxqt-admin-0.11.1-5.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2017-06-19 21:49:31 EDT
lxqt-admin-0.11.1-5.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.