Bug 1459671 - mariadb fails to start with tokudb; jemalloc not correctly enabled
mariadb fails to start with tokudb; jemalloc not correctly enabled
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mariadb (Show other bugs)
24
All All
unspecified Severity medium
: ---
: ---
Assigned To: Michal Schorm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-07 14:29 EDT by Michael Hampton
Modified: 2017-06-16 19:43 EDT (History)
8 users (show)

See Also:
Fixed In Version: mariadb-10.1.24-3.fc26 mariadb-10.1.24-3.fc24 mariadb-10.1.24-3.fc25
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-16 09:17:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to enable jemalloc (433 bytes, patch)
2017-06-08 06:10 EDT, Michael Hampton
no flags Details | Diff

  None (edit)
Description Michael Hampton 2017-06-07 14:29:22 EDT
Description of problem:
In current builds of mariadb, jemalloc is documented as enabled, but is not actually enabled.


Version-Release number of selected component (if applicable):
mariadb-10.1.24-1.fc24
mariadb-10.1.24-1.fc25
mariadb-10.1.24-1.fc26
mariadb-10.1.24-1.fc27


How reproducible:
Always


Steps to Reproduce:
1. Install mariadb-server
2. Attempt to enable tokudb in my.cnf with plugin-load-add=ha_tokudb.so
3. systemctl start mariadb


Actual results:
mariadb fails to start with errors:
2017-06-07 18:16:37 140270400252096 [ERROR] TokuDB is not initialized because jemalloc is not loaded
2017-06-07 18:16:37 140270400252096 [ERROR] Plugin 'TokuDB' init function returned error.
2017-06-07 18:16:37 140270400252096 [ERROR] Plugin 'TokuDB' registration as a STORAGE ENGINE failed.


Expected results:
mariadb should start normally and tokudb engine should be available.


Additional info:
The build log in koji also reveals that jemalloc wasn't actually built in:

CMake Warning at storage/tokudb/CMakeLists.txt:33 (MESSAGE):
  TokuDB is enabled, but jemalloc is not.  This configuration is not
  supported

It appears that the problem is "-DWITH_JEMALLOC=ON" in the %configure line. This form is not correct; like the other feature defines, it should be "-DWITH_JEMALLOC=system".
Comment 1 Michal Schorm 2017-06-08 03:22:18 EDT
Thanks for the report.

I'm working on the fix.
I won't push any current mariadb Bodhi update to the stable.
Comment 2 Michael Hampton 2017-06-08 06:10 EDT
Created attachment 1286099 [details]
Patch to enable jemalloc

It's a pretty trivial patch to get this fixed.
Comment 3 Fedora Update System 2017-06-08 12:07:46 EDT
mariadb-10.1.24-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d04e48112b
Comment 4 Fedora Update System 2017-06-08 12:08:08 EDT
mariadb-10.1.24-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-89daff1f64
Comment 5 Fedora Update System 2017-06-08 12:08:23 EDT
mariadb-10.1.24-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-120af70498
Comment 6 Fedora Update System 2017-06-09 09:31:44 EDT
mariadb-10.1.24-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d04e48112b
Comment 7 Fedora Update System 2017-06-09 09:40:58 EDT
mariadb-10.1.24-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-89daff1f64
Comment 8 Fedora Update System 2017-06-09 10:04:15 EDT
mariadb-10.1.24-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8425f676f2
Comment 9 Fedora Update System 2017-06-09 10:04:34 EDT
mariadb-10.1.24-3.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-2c0609b92a
Comment 10 Fedora Update System 2017-06-09 10:04:47 EDT
mariadb-10.1.24-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-09dd8907da
Comment 11 Fedora Update System 2017-06-10 08:31:29 EDT
mariadb-10.1.24-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8425f676f2
Comment 12 Fedora Update System 2017-06-10 08:34:23 EDT
mariadb-10.1.24-3.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-2c0609b92a
Comment 13 Fedora Update System 2017-06-12 00:38:28 EDT
mariadb-10.1.24-3.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-09dd8907da
Comment 14 Fedora Update System 2017-06-16 09:17:33 EDT
mariadb-10.1.24-3.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2017-06-16 13:49:52 EDT
mariadb-10.1.24-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2017-06-16 14:51:44 EDT
mariadb-10.1.24-3.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.
Comment 17 Michal Schorm 2017-06-16 19:43:47 EDT
Build reached stable repositories.

Note You need to log in before you can comment on or make changes to this bug.