Bug 1459697 - [ceph-ansible] [ceph-container] : Intsallation fails with 'ceph-ansible-2.2.10-1.el7' and few variables are missing in config files
[ceph-ansible] [ceph-container] : Intsallation fails with 'ceph-ansible-2.2.1...
Status: CLOSED ERRATA
Product: Red Hat Storage Console
Classification: Red Hat
Component: ceph-ansible (Show other bugs)
2
x86_64 Linux
unspecified Severity urgent
: ---
: 2
Assigned To: leseb
ceph-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-07 17:10 EDT by Rachana Patel
Modified: 2017-06-19 09:18 EDT (History)
8 users (show)

See Also:
Fixed In Version: ceph-ansible-2.2.11-1.el7scon
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-19 09:18:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rachana Patel 2017-06-07 17:10:32 EDT
Description of problem:
=======================

have 2 problems with containerized cluster installation using 'ceph-ansible-2.2.10-1.el7'

1. Installation fails with error "choose an upstream installation source or read https://github.com/ceph/ceph-ansible/wiki"

even though all required variables are set as per Document.



2. below is list of variable those were part of previous ceph-ansible but missing in current version ( not a complete list)



#osd_containerized_deployment: false
  #osd_containerized_deployment_with_kv: false
  #kv_type: etcd
  #kv_endpoint: 127.0.0.1
  #kv_port: 4001
  #ceph_docker_image: "ceph/daemon
  #ceph_docker_image_tag: latest                                                                                                                                               
  #ceph_docker_on_openstack: false         

  # III. Use directory instead of disk for OSDs
  # Use 'true' to enable this scenario

  #osd_directory: false
  #osd_directories
  #  - /var/lib/ceph/osd/mydir1
  #  - /var/lib/ceph/osd/mydir2
  #osd_directories: []   


  #mon_containerized_deployment_with_kv: false                                                                        
  #mon_containerized_deployment: false


Are those variables removed intentionally or by mistake.


Version-Release number of selected component (if applicable):
==============================================================
ceph-ansible-2.2.10-1.el7

How reproducible:
================
always
Comment 4 Andrew Schoen 2017-06-07 17:14:11 EDT
This was also reported by https://bugzilla.redhat.com/show_bug.cgi?id=1459639. The v2.2.10 tag of ceph-ansible was created incorrectly created and I've now created v2.2.11 to resolve the issue.
Comment 7 Rachana Patel 2017-06-07 21:50:32 EDT
verified version - ceph-ansible-2.2.11-1.el7scon
working as expected hence moving to verified
Comment 11 errata-xmlrpc 2017-06-19 09:18:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1496

Note You need to log in before you can comment on or make changes to this bug.