Bug 1459698 - [RFE] Service Name and/or Route Name for Registry in Default dockercfg secrets [NEEDINFO]
[RFE] Service Name and/or Route Name for Registry in Default dockercfg secrets
Status: CLOSED DEFERRED
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
3.5.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Michal Fojtik
Xiaoli Tian
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-07 17:50 EDT by Steven Walter
Modified: 2018-03-12 09:54 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-12 09:54:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
erich: needinfo? (mfojtik)


Attachments (Terms of Use)

  None (edit)
Description Steven Walter 2017-06-07 17:50:23 EDT
1. Proposed title of this feature request
 Service Name and/or Route Name for Registry in Default dockercfg secrets

3. What is the nature and description of the request?
 Customer would like to refer to images via the docker-registry service name and/or docker-registry route hostname in their dc's, rc's, and templates. This causes issues because the dockercfg that is automatically created for each project only refers to the registry svc ip address. This was noticed in https://bugzilla.redhat.com/show_bug.cgi?id=1448217 where it was suggested to open an RFE if it is desired to have svc name or route used.

4. Why does the customer need this? (List the business requirements here)
 Ease of use, not being forced to use an ip address for image names, etc.

5. How would the customer like to achieve this? (List the functional requirements here)
 Automatically update dockercfg to use docker-registry.default.svc.cluster.local, and when this is exposed to also include the hostname

6. For each functional requirement listed in question 5, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.
 Create a dc with service name (which is routable in the cluster already) or exposed hostname, image can pull automatically without manually changing dockercfg.

7. Is there already an existing RFE upstream or in Red Hat bugzilla?
 No

10. List any affected packages or components.
 .dockercfg secrets
Comment 3 Eric Rich 2018-03-12 09:54:36 EDT
This bug has been identified as a dated (created more than 3 months ago) bug. 
This bug has been triaged (has a trello card linked to it), or reviewed by Engineering/PM and has been put into the product backlog, 
however this bug has not been slated for a currently planned release (3.9, 3.10 or 3.11), which cover our releases for the rest of the calendar year. 

As a result of this bugs age, state on the current roadmap and PM Score (being below 70), this bug is being Closed - Differed, 
as it is currently not part of the products immediate priorities.

Please see: https://docs.google.com/document/d/1zdqF4rB3ea8GmVIZ7qWCVYUaQ7-EexUrQEF0MTwdDkw/edit for more details.

Note You need to log in before you can comment on or make changes to this bug.