Bug 1459708 - [GSS] Glusterd crashes and core-dumps when starting a volume in FIPS mode.
[GSS] Glusterd crashes and core-dumps when starting a volume in FIPS mode.
Status: CLOSED DUPLICATE of bug 1459709
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Atin Mukherjee
Bala Konda Reddy M
: Triaged
Depends On: 1092840
  Show dependency treegraph
Reported: 2017-06-07 19:33 EDT by Oonkwee Lim_
Modified: 2017-06-07 19:45 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1092840
Last Closed: 2017-06-07 19:45:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Oonkwee Lim_ 2017-06-07 19:33:52 EDT
+++ This bug was initially created as a clone of Bug #1092840 +++

Description of problem:
When a system is running in FIPS mode, attempting to start volume will cause glusterd to crash and coredump. This is the backtrace that was obtained when I tried this on FIPS enabled rhel-6.5 machine.

(gdb) bt
#0  0x00007f8741f2a925 in raise () from /lib64/libc.so.6
#1  0x00007f8741f2c105 in abort () from /lib64/libc.so.6
#2  0x00007f87422f3ebf in OpenSSLDie () from /usr/lib64/libcrypto.so.10
#3  0x00007f87422fa619 in MD5_Init () from /usr/lib64/libcrypto.so.10
#4  0x00007f87422fa9ea in MD5 () from /usr/lib64/libcrypto.so.10
#5  0x00007f874391c91c in md5_wrapper (data=<value optimized out>, len=<value optimized out>, md5=0x23057d0 "") at common-utils.c:68
#6  0x00007f873e8beb72 in glusterd_set_socket_filepath (sock_filepath=0x2306860 "/var/lib/glusterd/vols/test/run/", sockpath=0x230c9d0 "", len=4096) at glusterd-utils.c:1222
#7  0x00007f873e8bedf8 in glusterd_set_brick_socket_filepath (volinfo=0xfffffffffdcf87a1, brickinfo=0x7f8728003400, sockpath=0x230c9d0 "", len=4096) at glusterd-utils.c:1251
#8  0x00007f873e8c54a9 in glusterd_volume_start_glusterfs (volinfo=0x7f8728000f70, brickinfo=0x7f870000c000, wait=_gf_true) at glusterd-utils.c:1417
#9  0x00007f873e8c6f29 in glusterd_brick_start (volinfo=0x7f8728000f70, brickinfo=0x7f8728003400, wait=_gf_true) at glusterd-utils.c:4698
#10 0x00007f873e901a8d in glusterd_op_start_volume (dict=<value optimized out>, op_errstr=<value optimized out>) at glusterd-volume-ops.c:1746
#11 0x00007f873e8b071b in glusterd_op_commit_perform (op=GD_OP_START_VOLUME, dict=0x7f8740b3025c, op_errstr=0x2311868, rsp_dict=0x7f8740b3048c) at glusterd-op-sm.c:4170
#12 0x00007f873e90d93e in gd_commit_op_phase (peers=0x210e6e0, op=GD_OP_START_VOLUME, op_ctx=0x7f8740b301d0, req_dict=0x7f8740b3025c, op_errstr=0x2311868, npeers=0) at glusterd-syncop.c:980
#13 0x00007f873e90f632 in gd_sync_task_begin (op_ctx=0x7f8740b301d0, req=0x2101c6c) at glusterd-syncop.c:1260
#14 0x00007f873e90f76b in glusterd_op_begin_synctask (req=0x2101c6c, op=<value optimized out>, dict=0x7f8740b301d0) at glusterd-syncop.c:1294
#15 0x00007f873e902cc6 in __glusterd_handle_cli_start_volume (req=0x2101c6c) at glusterd-volume-ops.c:255
#16 0x00007f873e896f7f in glusterd_big_locked_handler (req=0x2101c6c, actor_fn=0x7f873e902b10 <__glusterd_handle_cli_start_volume>) at glusterd-handler.c:77
#17 0x00007f874393d8e2 in synctask_wrap (old_task=<value optimized out>) at syncop.c:293
#18 0x00007f8741f3bbf0 in ?? () from /lib64/libc.so.6
#19 0x0000000000000000 in ?? ()

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start up the system in FIPS mode
2. Create and try to start a volume.

Actual results:
Glusterd crashes with the above backtrace.

Expected results:
Glusterd shouldn't be crashing.

Additional info:
This is happening because glusterd is using MD5 to calculate a hash when building brick socket file path. MD5 is not a FIPS compliant hash algorithm, and openssl will die when an attempt to use MD5 is made in FIPS mode.

This was originally observed and reported on the gluster-users mailing list. The mail thread can be viewed at http://supercolony.gluster.org/pipermail/gluster-users/2014-April/040060.html.
Comment 2 Oonkwee Lim_ 2017-06-07 19:45:13 EDT

*** This bug has been marked as a duplicate of bug 1459709 ***

Note You need to log in before you can comment on or make changes to this bug.