Bug 1459781 - Brick Multiplexing:Even clean Deleting of the brick directories of base volume is resulting in posix health check errors(just as we see in ungraceful delete methods)
Brick Multiplexing:Even clean Deleting of the brick directories of base volum...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
mainline
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Mohit Agrawal
brick-multiplexing
:
Depends On: 1451602
Blocks: 1457219
  Show dependency treegraph
 
Reported: 2017-06-08 03:33 EDT by Mohit Agrawal
Modified: 2017-09-05 13:33 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.12.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1451602
Environment:
Last Closed: 2017-09-05 13:33:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Worker Ant 2017-06-08 03:40:23 EDT
REVIEW: https://review.gluster.org/17492 (glusterfsd: Deletion of brick dir throw emerg msgs after stop volume) posted (#1) for review on master by MOHIT AGRAWAL (moagrawa@redhat.com)
Comment 2 Worker Ant 2017-06-09 18:43:57 EDT
COMMIT: https://review.gluster.org/17492 committed in master by Jeff Darcy (jeff@pl.atyp.us) 
------
commit 5b82f173ba337b2fe06846c2a0e5f35d1ff53357
Author: Mohit Agrawal <moagrawa@redhat.com>
Date:   Thu Jun 8 13:04:42 2017 +0530

    glusterfsd: Deletion of brick dir throw emerg msgs after stop volume
    
    Problem: Deletion of brick directories throw emerg messages after stop
             volume while brick mux is enabled.
    
    Solution: Modify the posix health check monitor thread code to
              handled correctly.
    
    BUG: 1459781
    Signed-off-by: Mohit Agrawal <moagrawa@redhat.com>
    
    Change-Id: I2d22a84f9a98b0da261e5fb7850ba1368f3601d7
    Reviewed-on: https://review.gluster.org/17492
    Tested-by: MOHIT AGRAWAL <moagrawa@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-by: Jeff Darcy <jeff@pl.atyp.us>
Comment 3 Shyamsundar 2017-09-05 13:33:35 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.