Bug 1459789 - OpenDaylight + SRIOV deployment fails - Could not find data item neutron::plugins::ml2::mechanism_drivers
Summary: OpenDaylight + SRIOV deployment fails - Could not find data item neutron::plu...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 12.0 (Pike)
Assignee: Tim Rozet
QA Contact: Itzik Brown
URL:
Whiteboard:
Depends On:
Blocks: 1414427 1528947
TreeView+ depends on / blocked
 
Reported: 2017-06-08 07:52 UTC by Itzik Brown
Modified: 2018-10-18 07:23 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-heat-templates-7.0.0-0.20170805163048.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2017-12-13 21:31:55 UTC
Target Upstream Version:


Attachments (Terms of Use)
Part of the deployment's log (4.00 KB, text/plain)
2017-06-08 07:52 UTC, Itzik Brown
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 1696667 None None None 2017-06-08 07:52:31 UTC
OpenStack gerrit 486187 None None None 2017-07-21 17:46:15 UTC
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Itzik Brown 2017-06-08 07:52:31 UTC
Created attachment 1286064 [details]
Part of the deployment's log

Description of problem:
When deploying OpenStack with OpenDaylight and SR-IOV the deployment fails.
I attached the error.

It seems that the problem is in environments/neutron-opendaylight.yaml which includes
OS::TripleO::Services::ComputeNeutronCorePlugin: OS::Heat::None

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-6.0.0-10.el7ost.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Nir Yechiel 2017-07-20 09:04:18 UTC
I this still valid?

Comment 2 Itzik Brown 2017-07-20 10:29:22 UTC
As far as I know - yes.

Comment 3 Nir Yechiel 2017-07-20 10:35:48 UTC
@Tim, can you take a look at this?

Comment 4 Tim Rozet 2017-07-21 16:55:04 UTC
This is a bug, will fix it.  We need a new environment file for ODL + SRIOV as the current combination will not work (no ML2 compute plugin, and openvswitch used as mech driver).

Comment 5 Nir Yechiel 2017-08-04 15:28:47 UTC
Merged upstream.

Comment 7 Itzik Brown 2017-08-31 12:31:56 UTC
Checked with:
openstack-tripleo-heat-templates-7.0.0-0.20170805163048.el7ost.noarch

When using SR-IOV +ODL the following environment file should be used:
/usr/share/openstack-tripleo-heat-templates/environments/neutron-sriov.yaml

Comment 10 errata-xmlrpc 2017-12-13 21:31:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.