Bug 1459790 - [Snapshot].snaps directory is not visible in windows client
[Snapshot].snaps directory is not visible in windows client
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: snapshot (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.3.0
Assigned To: Mohammed Rafi KC
Anil Shah
:
Depends On:
Blocks: 1417151
  Show dependency treegraph
 
Reported: 2017-06-08 03:53 EDT by Vivek Das
Modified: 2017-09-21 00:59 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.8.4-28
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-21 00:59:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vivek Das 2017-06-08 03:53:08 EDT
Description of problem:
With all the VSS plugins and USS plugins enabled over a volume (which is mounted over a windows machine), .snaps is not visible in that share.
Though restore of snapshot works.

Version-Release number of selected component (if applicable):
samba-client-4.6.3-2.el7rhgs.x86_64
glusterfs-3.8.4-27.el7rhgs.x86_64

How reproducible:
Always

Steps to Reproduce:
1.Enable VSS & USS plugins for a volume
2.Mount the volume in windows client
3.check for .snaps

Actual results:
.snaps not visible

Expected results:
.snaps should be visible

Additional info:
Volume Name: topgun
Type: Distributed-Replicate
Volume ID: 7a2b0cc2-134e-4c28-b901-7a66fa80d660
Status: Started
Snapshot Count: 1
Number of Bricks: 2 x 2 = 4
Transport-type: tcp
Bricks:
Brick1: dhcp47-127.lab.eng.blr.redhat.com:/bricks/brick5/topgun_brick0
Brick2: dhcp46-181.lab.eng.blr.redhat.com:/bricks/brick5/topgun_brick1
Brick3: dhcp46-47.lab.eng.blr.redhat.com:/bricks/brick4/topgun_brick2
Brick4: dhcp47-140.lab.eng.blr.redhat.com:/bricks/brick4/topgun_brick3
Options Reconfigured:
performance.cache-samba-metadata: on
network.inode-lru-limit: 50000
performance.md-cache-timeout: 600
performance.cache-invalidation: on
features.cache-invalidation-timeout: 600
features.cache-invalidation: on
nfs.disable: on
transport.address-family: inet
server.allow-insecure: on
performance.stat-prefetch: on
storage.batch-fsync-delay-usec: 0
performance.parallel-readdir: on
performance.nl-cache: on
features.uss: enable
features.show-snapshot-directory: enable
features.barrier: disable
Comment 2 Mohammed Rafi KC 2017-06-09 03:29:51 EDT
Upstream patch : https://review.gluster.org/#/c/17465/
Comment 5 Mohammed Rafi KC 2017-06-13 03:41:17 EDT
Downstream patch : https://code.engineering.redhat.com/gerrit/#/c/108901/
Comment 6 Atin Mukherjee 2017-06-13 03:51:55 EDT
downstream patch : https://code.engineering.redhat.com/gerrit/108901
Comment 8 Anil Shah 2017-06-28 07:55:52 EDT
.snaps is visible on windows client, when uss and vss plugins are enabled.

bug verified on builds glusterfs-fuse-3.8.4-31.el7rhgs.x86_64 and samba-4.6.3-3.el7rhgs.x86_64
Comment 10 errata-xmlrpc 2017-09-21 00:59:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2774

Note You need to log in before you can comment on or make changes to this bug.