Bug 1459792 - ovirt uri cannot be saved after connecting to guest successfully
ovirt uri cannot be saved after connecting to guest successfully
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.4
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Eduardo Lima (Etrunko)
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-08 04:11 EDT by xiaodwan
Modified: 2018-04-10 04:51 EDT (History)
9 users (show)

See Also:
Fixed In Version: virt-viewer-5.0-9.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 04:50:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-viewer debug log (3.69 KB, application/octet-stream)
2017-06-08 04:13 EDT, xiaodwan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0672 None None None 2018-04-10 04:51 EDT

  None (edit)
Description xiaodwan 2017-06-08 04:11:48 EDT
Description of problem:
ovirt uri cannot be saved after connecting to guest successfully. 

Version-Release number of selected component (if applicable):
virt-viewer-5.0-7.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Run "remote-viewer --ovirt-ca-file=xxx ovirt://xxxx/xxxx" to connect to a guest succesfully.
2. Run "remote-viewer --ovirt-ca-file=xxx", check the recent connections in recent dialog.

Actual results:
The ovirt uri is not listed in recent dialog.

Expected results:
The ovirt uri should be listed in recent dialog.

Additional info:
Comment 2 xiaodwan 2017-06-08 04:13 EDT
Created attachment 1286065 [details]
virt-viewer debug log
Comment 5 Eduardo Lima (Etrunko) 2017-10-20 13:12:37 EDT
Patch sent to mailing list, waiting for review.

https://www.redhat.com/archives/virt-tools-list/2017-October/msg00039.html
Comment 6 Eduardo Lima (Etrunko) 2017-11-17 07:54:52 EST
Pushed upstream as 6608c0dd60fbf3a762a21a4d039fefc75c040406.
Comment 10 xiaodwan 2017-11-22 03:55:23 EST
Now there is a problem, when the guest specified in ovirt url doesn't exist in rhevm, a dialog will pop up and ask you to select one if rhevm has running guests. And then if you select one and connect to it successfully, remote-viewer will remember the wrong ovirt url.

You can ignore the invalid url or correct the wrong guest name to the guest name you selected.

I prefer to correct it automatically.
Comment 11 Eduardo Lima (Etrunko) 2017-11-22 13:14:24 EST
(In reply to xiaodwan from comment #10)
> Now there is a problem, when the guest specified in ovirt url doesn't exist
> in rhevm, a dialog will pop up and ask you to select one if rhevm has
> running guests. And then if you select one and connect to it successfully,
> remote-viewer will remember the wrong ovirt url.
> 
> You can ignore the invalid url or correct the wrong guest name to the guest
> name you selected.
> 
> I prefer to correct it automatically.

This is something to think about, some similar use cases could be:

1) There is no VM specified with the URI. This will also show the VM selection dialog and should we save the URI as specified by the command line or include the selected VM?

2) VM exists but is down, the selection dialog will also be shown, and if user selects different VM?

3) Username is specified in the URI, but user changes it in the dialog asking for the password, which should be saved?
Comment 14 xiaodwan 2017-11-23 22:27:32 EST
The problem in this bug has been fixed in virt-viewer-5.0-9.el7.x86_64.

For other problems, i filed a new bug to track them.
Bug 1517040 - RFE: improve the logic when saving ovirt url

So move the bug from ON_QA to VERIFIED.
Comment 17 errata-xmlrpc 2018-04-10 04:50:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0672

Note You need to log in before you can comment on or make changes to this bug.