Bug 1459794 - Touchpad not working after closing laptop lid
Touchpad not working after closing laptop lid
Status: CLOSED DUPLICATE of bug 1431375
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
26
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-08 04:17 EDT by Denis Tatina
Modified: 2017-06-26 06:04 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-26 06:04:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Evemu record of lid switch (2.67 KB, text/plain)
2017-06-09 03:36 EDT, Denis Tatina
no flags Details
Libinput debug events (14.09 KB, text/plain)
2017-06-09 03:39 EDT, Denis Tatina
no flags Details
Dmesq log from boot, suspend and resume (67.96 KB, text/plain)
2017-06-26 05:45 EDT, Denis Tatina
no flags Details

  None (edit)
Description Denis Tatina 2017-06-08 04:17:32 EDT
Description of problem:

After closing laptop lid and re-opening it touchpad stop's working at all. Although I can use keyboard and touchscreen normally without any problem. Reboot is necessary to make it working again.

Version-Release number of selected component (if applicable):
1.7.2-2.fc26 

How reproducible:

1. Close laptop lid.
2. Open laptop lid.
3. Touchpad is not working.

Actual results:
Touchpad is not working.

Expected results:
Touchpad works.

Additional info:
My notebook is Lenovo Yoga 3 Pro. I'm running Fedora 26 (Gnome with Wayland session) with all latest updates. I don't know if it's connected with libinput, but in previous Fedora version (25) everything works like a charm.
Comment 1 Peter Hutterer 2017-06-09 00:34:21 EDT
probably libinput, F26 has a lid switch handling that disables the touchpad when the lid is closed to avoid ghost touches. This should work normally though, unless the lid switch is unreliable (and not marked as such).
https://who-t.blogspot.com.au/2017/02/libinput-and-lid-switch-events.html

So the first thing to do is: run sudo evemu-record against the lid switch device after resume and attach the output here, I wonder if the state remains as closed.

Also run sudo libinput-debug-events --verbose in a terminal and then suspend+resume, that should give us some hint too.
Comment 2 Denis Tatina 2017-06-09 03:36 EDT
Created attachment 1286318 [details]
Evemu record of lid switch

1) run sudo evemu-record
2) Choose lid switch event
3) Close lid
4) Resume noteboook
5) Enter password
6) Enter CTRL+C in console
7) Save console output
Comment 3 Denis Tatina 2017-06-09 03:39 EDT
Created attachment 1286320 [details]
Libinput debug events

1) run sudo libinput-debug-events --verbose
2) Close lid
3) Resume notebook
4) Enter password
5) Use touchpad (doesn't work, no " event14  POINTER_MOTION" in console), keyboard (works) and touchscreen (works)
5) CTRL+C in console
6) Save console output
Comment 4 Peter Hutterer 2017-06-09 19:35:58 EDT
ok, the lid switch log and the debug log look correct and libinput detects the lid being opened. so let's rule out the last thing: run sudo evemu-record and select the touchpad device, does the kernel device send events after suspend?
Comment 5 Denis Tatina 2017-06-10 03:58:18 EDT
I've tested it with evemu, and You are right. After resume kernel device (touchpad selected in evemu-record) doesn't send any events.
Comment 6 Benjamin Tissoires 2017-06-26 04:29:03 EDT
Sorry for the delay.

Could you attach a dmesg from the boot, containing the suspend resume action in it too?
Comment 7 Denis Tatina 2017-06-26 05:45 EDT
Created attachment 1291937 [details]
Dmesq log from boot, suspend and resume

Boot pc, log in, close lid, open lid, touchpad doesn't work anymore.
Comment 8 Benjamin Tissoires 2017-06-26 06:04:05 EDT
Thanks for the log. The dmesg shows that this is the exact same issue than bug #1431375, so closing this one as a dup, and continuing to work on that in bug #1431375

*** This bug has been marked as a duplicate of bug 1431375 ***

Note You need to log in before you can comment on or make changes to this bug.