Bug 1459800 - remote-viewer should pop up the recent dialog instead of a main window when running "remote-viewer -k"
remote-viewer should pop up the recent dialog instead of a main window when r...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.4
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Victor Toso
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-08 04:22 EDT by xiaodwan
Modified: 2018-04-10 04:51 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 04:50:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
remote viewer recent dialg (26.68 KB, image/png)
2017-10-19 03:45 EDT, xiaodwan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0672 None None None 2018-04-10 04:51 EDT

  None (edit)
Description xiaodwan 2017-06-08 04:22:16 EDT
Description of problem:
remote-viewer should pop up the recent dialog instead of a main window when running "remote-viewer -k" 

Version-Release number of selected component (if applicable):
virt-viewer-5.0-7.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Run "remote-viewer -k" in terminal.

Actual results:
A blank main window displays in fullscreen.

Expected results:
The recent dialog should pop up. 
when users type correct uri, and then click connect button, remote-viewer can enter kiosk mode.

Additional info:
Comment 2 Victor Toso 2017-06-09 11:32:55 EDT
Could you please confirm that the recent dialog pop up actualy exists but it is hidden on kiosk mode? Alt + ` after running remote-viewer should make the recent dialog to show.
Comment 4 xiaodwan 2017-06-11 22:21:29 EDT
(In reply to Victor Toso from comment #2)
> Could you please confirm that the recent dialog pop up actualy exists but it
> is hidden on kiosk mode? Alt + ` after running remote-viewer should make the
> recent dialog to show.

yes, the recent dialog has already been popped but sits under the main window.
Comment 5 Victor Toso 2017-06-12 09:39:32 EDT
Pushed upstream: 58dd08f222b49781b0e11d4e067d6cd85e16676d
Comment 7 xiaodwan 2017-10-19 03:43:37 EDT
Hi, i tested this bug with virt-viewer-5.0-8.el7.x86_64 and gnome-desktop3-3.22.2-2.el7.x86_64, the dialog sits above the main window now.

But the recent dialog is on top-left corner of the main window and doesn't have focus. Pls see the screenshot of this problem.

Thanks
xiaodwan
Comment 8 xiaodwan 2017-10-19 03:45 EDT
Created attachment 1340577 [details]
remote viewer recent dialg
Comment 10 Eduardo Lima (Etrunko) 2017-10-31 11:37:44 EDT
I will check if the build you mentioned ships the fix for this bug.
(In reply to xiaodwan from comment #7)
> Hi, i tested this bug with virt-viewer-5.0-8.el7.x86_64 and
> gnome-desktop3-3.22.2-2.el7.x86_64, the dialog sits above the main window
> now.
> 
> But the recent dialog is on top-left corner of the main window and doesn't
> have focus. Pls see the screenshot of this problem.


Yes, the build includes the fix for the problem, but for repositioning the dialog in the center of the main window we need another patch, which is not in the build and in fact could be tracked in another bz.
Comment 12 tingting zheng 2017-10-31 23:14:12 EDT
(In reply to Eduardo Lima (Etrunko) from comment #10)
> I will check if the build you mentioned ships the fix for this bug.
> (In reply to xiaodwan from comment #7)
> > Hi, i tested this bug with virt-viewer-5.0-8.el7.x86_64 and
> > gnome-desktop3-3.22.2-2.el7.x86_64, the dialog sits above the main window
> > now.
> > 
> > But the recent dialog is on top-left corner of the main window and doesn't
> > have focus. Pls see the screenshot of this problem.
> 
> 
> Yes, the build includes the fix for the problem, but for repositioning the
> dialog in the center of the main window we need another patch, which is not
> in the build and in fact could be tracked in another bz.

Xiaodai,would you pls check the comments and report a new bug for the above issue,thanks.
Comment 13 xiaodwan 2017-10-31 23:22:56 EDT
> Yes, the build includes the fix for the problem, but for repositioning the
> dialog in the center of the main window we need another patch, which is not
> in the build and in fact could be tracked in another bz.

I created bug 1459800 for the wrong position of the recent dialog, and move this bug from ON_QA to VERIFIED.

Thanks
Comment 14 xiaodwan 2017-10-31 23:24:49 EDT
(In reply to xiaodwan from comment #13)
> > Yes, the build includes the fix for the problem, but for repositioning the
> > dialog in the center of the main window we need another patch, which is not
> > in the build and in fact could be tracked in another bz.
> 
> I created bug 1459800 for the wrong position of the recent dialog, and move
> this bug from ON_QA to VERIFIED.
> 
> Thanks

Sorry, bug 1508274.
Comment 17 errata-xmlrpc 2018-04-10 04:50:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0672

Note You need to log in before you can comment on or make changes to this bug.