Bug 145981 - cpuspeed triggers on disk i/o.
Summary: cpuspeed triggers on disk i/o.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel-utils   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-24 14:44 UTC by Pierre Ossman
Modified: 2015-01-04 22:16 UTC (History)
1 user (show)

Fixed In Version: 1.2.1-1.23_FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-14 14:04:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to measure iowait (1.57 KB, patch)
2005-03-11 17:46 UTC, Pierre Ossman
no flags Details | Diff

Description Pierre Ossman 2005-01-24 14:44:44 UTC
Description of problem:
cpuspeed inreases cpu frequency when there is a lot of disk i/o. I.e.
when a lot of time is spent in 'waiting'. This causes a lot of wasted
power since disk i/o won't increase just because the cpu is faster
(since that's rarely the bottle neck).

Version-Release number of selected component (if applicable):
2.4-13.1.39

How reproducible:
Every time.

Comment 1 Dave Jones 2005-02-13 04:12:43 UTC
are your disks in DMA mode ?


Comment 2 Pierre Ossman 2005-02-13 18:27:19 UTC
Yes they are.

Running 'dd if=/dev/hda of=/dev/null' puts the cpu in full speed and top reports:

Cpu(s):  3.3% us,  9.3% sy,  0.0% ni,  0.0% id, 85.4% wa,  2.0% hi,  0.0% si

Comment 3 Pierre Ossman 2005-03-11 17:46:48 UTC
Created attachment 111898 [details]
Patch to measure iowait

This patch gives the desired behaviour.

Comment 4 Pierre Ossman 2005-10-14 14:04:13 UTC
Modern cpuspeed has this behaviour. Marking as resolved.


Note You need to log in before you can comment on or make changes to this bug.