Bug 1459901 - Answer file saved by config-proxy.sh after resumed installation not complete
Answer file saved by config-proxy.sh after resumed installation not complete
Status: CLOSED ERRATA
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer (Show other bugs)
580
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Tomáš Kašpárek
Pavel Studeník
:
Depends On:
Blocks: sat58-errata sat58-nth
  Show dependency treegraph
 
Reported: 2017-06-08 09:43 EDT by Radovan Drazny
Modified: 2018-01-28 09:45 EST (History)
2 users (show)

See Also:
Fixed In Version: spacewalk-proxy-installer-2.5.0-13-sat
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-01-28 09:45:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radovan Drazny 2017-06-08 09:43:32 EDT
Description of problem:
If you install RHN Proxy using the config-proxy.sh command and the installation fails for some reason, it saves a proxy-answers.txt.XXXX file. If you use this file for another (successful) installation run, installer writes a new answer file. This file contains only choices selected during the second run, not all choices made in whole installation.

Version-Release number of selected component (if applicable):
spacewalk-proxy-installer-2.5.0-10.el6sat

How reproducible:
always

Steps to Reproduce:
1. Prepare a machine for the RHN Proxy install, and install the spacewalk-proxy-installer package.
2. Run the config-proxy.sh command. 
3. Enter wrong proxy version to activate to produce an error during the installation, and anwer Y to question if you want to save an answer file.
4. Fix the resulting proxy-answers.txt.XXXX file to contain correct VERSION field.
5. Run "config-proxy.sh --answer-file proxy-answer.txt.XXXX", using the answer file created in the previous step.
6. Finish the installation, and again let the installer save a answer file at the end.
7. Check the final answer file created in step 6. It will contain only choices made in the second run of the installer, not the ones imported from the answer file created in step 4.

Actual results:
Resulting answer file is incomplete.

Expected results:
Resulting answer file should contain all choices made during the installation, including the ones from the first run of the installer.

Additional info:

$ configure-proxy.sh
Using RHN parent (from /etc/sysconfig/rhn/up2date): parent.satellite.server.com
Using CA Chain (from /etc/sysconfig/rhn/up2date): /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT
HTTP Proxy []:
Proxy version to activate [5.8]: 5.9
<...>
There was a problem activating the Red Hat Satellite Proxy entitlement:
ERROR: upon entitlement/activation attempt: unknown error - <Fault 1046: 'redstone.xmlrpc.XmlRpcFault: proxy_channel_not_found'>
Proxy activation failed! Installation interrupted.
There were some answers you had to enter manually.
Would you like to have written those into file
formatted as answers file? [Y/n]: y
Writing proxy-answers.txt.53LRu

$ sed -i s/VERSION=5.9/VERSION=5.8/g proxy-answers.txt.53LRu

$ configure-proxy.sh --answer-file proxy-answers.txt.53LRu
Using RHN parent (from /etc/sysconfig/rhn/up2date): parent.satellite.server.com
Using CA Chain (from /etc/sysconfig/rhn/up2date): /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT
HTTP Proxy []:
Proxy version to activate [5.8]: 5.8
<...>
There were some answers you had to enter manually.
Would you like to have written those into file
formatted as answers file? [Y/n]:
Writing proxy-answers.txt.rJYql

$ cat proxy-answers.txt.53LRu
# Answer file generated by configure-proxy.sh at Thu Jun  8 09:03:57 EDT 2017
HTTP_PROXY=''
VERSION=5.8
TRACEBACK_EMAIL=rdrazny@redhat.com
USE_SSL=Y/n
SSL_ORG=Red\ Hat
SSL_ORGUNIT=rhnproxy.server.com
SSL_COMMON=rhnproxy.server.com
SSL_CITY=Brno
SSL_STATE=Morava
SSL_COUNTRY=CZ
SSL_EMAIL=rdrazny@redhat.com
SSL_CNAME_ASK=''

$ cat proxy-answers.txt.rJYql
# Answer file generated by configure-proxy.sh at Thu Jun  8 09:09:28 EDT 2017
POPULATE_CONFIG_CHANNEL=Y/n
RHN_USER=admin
Comment 2 Tomáš Kašpárek 2017-10-04 04:33:29 EDT
spacewalk.git(master): 10741e8d0ad9c55a8e95f91a52477194acc6c5f2
Comment 5 Pavel Studeník 2018-01-08 08:22:11 EST
Verified with spacewalk-proxy-installer-2.5.0-13.el6sat.noarch.rpm
Comment 8 errata-xmlrpc 2018-01-28 09:45:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0137

Note You need to log in before you can comment on or make changes to this bug.