Bug 1459912 - BIOS CMOS settings spoiled, after restart kernel 4.11. with Intel 7260 bluetooth [8087:07dc] disabled.
BIOS CMOS settings spoiled, after restart kernel 4.11. with Intel 7260 blueto...
Status: CLOSED DUPLICATE of bug 1479014
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
26
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-08 10:16 EDT by izyk
Modified: 2017-08-07 13:40 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-07 13:40:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Concatenaited dmesg output from kernels 4.10 and 4.11 (124.06 KB, text/plain)
2017-06-08 10:16 EDT, izyk
no flags Details
The output difference 'dmesg' of the both kernels. (34.43 KB, patch)
2017-06-16 03:57 EDT, izyk
no flags Details | Diff
diff-u_output_of_the kernel 4.11.4_good_boot 4.11.4_wrong_boot (31.28 KB, patch)
2017-07-25 04:18 EDT, izyk
no flags Details | Diff

  None (edit)
Description izyk 2017-06-08 10:16:46 EDT
Created attachment 1286168 [details]
Concatenaited dmesg output from kernels 4.10 and 4.11

Description of problem:
After update to '4.11.3-200.fc25.x86_64' and loading fedora 25.
Next time reboot will be with spoiled CMOS settings.
Bios detect this, display 'configuration changed - restart the system' 
and returns default settings.
Last normal kernel 4.10.17-200.fc25.x86_64

Version-Release number of selected component:
4.11.3-200.fc25.x86_64 (mockbuild@bkernel01.phx2.fedoraproject.org) (gcc version 6.3.1 20161221 (Red Hat 6.3.1-1) (GCC)

How reproducible:
Steps to Reproduce:
1. Turn on notebook
2. Load fedora 25 with kernel 4.11
3. Restart. 
4. Then an next boot time you see 'configuration changed - restart the system'

Actual results:
All CMOS settings returned to default.


Additional info:
Notebook - lenovo s540.
Load mode - legacy MBR. No EFI.
I try fedora vanilla 4.11.4 kernel with same result.
Kernel 4.10 all right.
Comment 1 izyk 2017-06-16 03:57 EDT
Created attachment 1288273 [details]
The output difference  'dmesg' of the both kernels.

dmesg -u output_4.10 output_4.11
Comment 2 izyk 2017-06-16 04:07:19 EDT
Please.
Does anybody know what a kernel changes can be reason of this behaviour?
Comment 3 izyk 2017-06-16 09:39:56 EDT
I have been trying many kernel acpi parameters.
(
acpi_force_32bit_fadt_addr acpi_enforce_resources=lax acpi=copy_dsdt acpi_apic_instance=2 acpi_osi=\"!Linux\" acpi_osi=\"Windows 2012\" pci=realloc=off,nocrs intel_iommu=off intremap=off"
acpi=noirq acpica_no_return_repair acpi_no_auto_serialize acpi_enforce_resources=no acpi_no_static_ssdt acpi_force_table_verification"
)
I have used the efi fedora26 beta.
Fedora-Workstation-Live-x86_64-26_Beta-1.4.iso with kernel 4.11 too.

But works without "CMOS reseting" only with 
acpi=off. :(
Comment 4 izyk 2017-07-25 04:18 EDT
Created attachment 1304096 [details]
diff-u_output_of_the kernel 4.11.4_good_boot 4.11.4_wrong_boot
Comment 5 izyk 2017-07-25 04:51:34 EDT
My system has two disks.

Perhaps after cloning the first disc on the second I forgot to wipe it completely. As a result, maybe, I had two disks with the same signature in the MBR. Now I have created a new MBR with new disk signature on one of the disks. 

Perhaps the changes in BIOS settings helped, I left the boot up only in normal(legacy) mode without the possibility of UEFI. After, the UEFI possibility was returned without troubles.

Now everything works as it should.

Sorry for any inconvenience.
Comment 6 izyk 2017-07-26 05:29:07 EDT
Everything works as it should, but
after I disable the bluetooth. BIOS can't see the adapter any more, and think that the hardware configuration changed -> Bios Reset CMOS Settings.
It happens only with kernels 4.11 and above. Doesn't happen with 4.10.




Windows 10 system log has:
EVENT 34 BTHUSB
The local adapter does not support an important Low Energy controller state to support peripheral mode. The minimum required supported state mask is 0x491f7fffff, got 0x1fffffff. Low Energy peripheral role functionality will not be available.
Comment 7 izyk 2017-07-26 13:41:15 EDT
workaround:
Keep the bluetooth always on.
Comment 8 izyk 2017-08-07 13:40:01 EDT

*** This bug has been marked as a duplicate of bug 1479014 ***

Note You need to log in before you can comment on or make changes to this bug.