Bug 1459926 - Zaqar websockets randomly disconnect
Zaqar websockets randomly disconnect
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director-ui (Show other bugs)
11.0 (Ocata)
Unspecified Unspecified
high Severity high
: ---
: 12.0 (Pike)
Assigned To: Honza Pokorny
Ola Pavlenko
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-08 11:09 EDT by Udi
Modified: 2017-10-16 07:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-16 07:43:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Udi 2017-06-08 11:09:46 EDT
Description of problem:
While working with the GUI, every so often an alert pops up: "Zaqar Websocket encountered Error". The easiest way to recreate it is to log in and out many times (it most often occurs on logins - maybe because it's heavily used in that stage when all the data is loaded?). 

This error also occurs during operations that take long, like role assignment or nodes registration, and when that happens it can cause the GUI to never see that the operation already finished (the spinner on the screen keeps spinning until you hit F5).


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-3.1.0-9.el7ost.noarch
openstack-zaqar-4.0.0-2.el7ost.noarch


How reproducible:
Randomly
Comment 3 Jason E. Rist 2017-10-12 12:27:41 EDT
Patches have all landed. Need another review of this bz.
Comment 4 Honza Pokorny 2017-10-16 07:43:59 EDT
Closing this as stale; I haven't seen this bug in months now, feel free to reopen if you encounter it again

Note You need to log in before you can comment on or make changes to this bug.