Bug 1459927 - rich rules are only syntax-checked, invalid rules are silently unapplied
Summary: rich rules are only syntax-checked, invalid rules are silently unapplied
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firewalld
Version: 7.4
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: rc
: ---
Assignee: Eric Garver
QA Contact: Jiri Peska
URL:
Whiteboard:
Depends On: 1637204
Blocks: 1472751
TreeView+ depends on / blocked
 
Reported: 2017-06-08 15:12 UTC by Tomas Dolezal
Modified: 2020-03-31 20:01 UTC (History)
6 users (show)

Fixed In Version: firewalld-0.6.3-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-31 20:00:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1109 None None None 2020-03-31 20:01:39 UTC

Description Tomas Dolezal 2017-06-08 15:12:00 UTC
Description of problem:
firewall-cmd --add-rich-rule 'rule service name=rainbowpony log'
The error is printed solely in syslog as
WARNING: INVALID_SERVICE: rainbowpony
this information is very useful for admin to see in the moment of rule creation

Version-Release number of selected component (if applicable):
firewalld-0.4.4.4-5.el7.noarch

How reproducible:
always

Steps to Reproduce:
firewall-cmd --add-rich-rule 'rule service name=rainbowpony log'


Actual results:
"success" is printed out

Expected results:
this output:
WARNING: INVALID_SERVICE: rainbowpony
success

Additional info:
should be similar to
Warning: ALREADY_ENABLED: 'rule service name="network-unreachable" log' already in 'public'
success

Comment 4 Eric Garver 2018-10-08 21:48:46 UTC
Fixed upstream:

    cc0fadae1eb5 ("fw_zone: do not change rich rule errors into warnings")

# firewall-cmd --add-rich-rule 'rule service name=rainbowpony log'
Error: INVALID_SERVICE: rainbowpony

Comment 10 errata-xmlrpc 2020-03-31 20:00:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1109


Note You need to log in before you can comment on or make changes to this bug.