Bug 1460005 - instance crashing because of edac
instance crashing because of edac
Status: CLOSED DUPLICATE of bug 1448312
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kernel (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: hwkernel-mgr@redhat.com
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-08 15:46 EDT by Yuri Arabadji
Modified: 2017-06-20 15:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-08 16:57:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log.txt (110.18 KB, text/plain)
2017-06-08 15:46 EDT, Yuri Arabadji
no flags Details

  None (edit)
Description Yuri Arabadji 2017-06-08 15:46:03 EDT
Created attachment 1286217 [details]
log.txt

When trying to debug a guest VM, it seems I'm not able to start a supermin instance during guestfish run.

Please, see attached log.

Thanks.


Manufacturer: Supermicro
Product Name: X9DRT-PIBF
BIOS Revision: 4.6


+ udevadm trigger
+ udevadm settle --timeout=600
[    0.774817] input: PC Speaker as /devices/platform/pcspkr/input/input3
[    0.802973] sd 2:0:0:0: Attached scsi generic sg0 type 0
[    0.805193] sd 2:0:1:0: Attached scsi generic sg1 type 0
[    0.832608] AVX version of gcm_enc/dec engaged.
[    0.833277] AES CTR mode by8 optimization enabled
[    0.858585] EDAC MC: Ver: 3.0.0
[    0.860316] EDAC sbridge:  Ver: 1.1.1 
[    0.860865] general protection fault: 0000 [#1] SMP
[    0.861494] Modules linked in: sb_edac(+) edac_core ghash_clmulni_intel pcbc aesni_intel crypto_simd glue_helper cryptd sg pcspkr ata_generic pata_acpi input_leds serio_raw libcrc32c crc8 crc7 crc_itu_t ext4 mbcache jbd2 virtio_pci virtio_input virtio_balloon virtio_scsi sd_mod nd_pmem nd_btt virtio_net virtio_crypto virtio_console virtio_rng virtio_blk virtio_ring virtio ata_piix libata crc32_generic crct10dif_pclmul crc32c_intel crc32_pclmul
[    0.866396] CPU: 0 PID: 379 Comm: systemd-udevd Not tainted 4.10.0-1.el7.elrepo.x86_64 #1
[    0.867426] Hardware name: Red Hat KVM, BIOS 0.5.1 01/01/2011
[    0.868165] task: ffff88001d2e8000 task.stack: ffffc9000034c000
[    0.868931] RIP: 0010:atomic_notifier_chain_register+0x31/0x60
[    0.869678] RSP: 0018:ffffc9000034fc38 EFLAGS: 00010082
[    0.870336] RAX: 0000000000000293 RBX: ffffffff81fb9b60 RCX: ffffffffa002b628
[    0.871256] RDX: 8b4c5354415541e5 RSI: ffffffffa0201000 RDI: ffffffff81fb9b60
[    0.872180] RBP: ffffc9000034fc48 R08: 0000000000000000 R09: 0000000000000137
[    0.873095] R10: 0000000000000005 R11: 0000000000000136 R12: ffffffffa0201000
[    0.874009] R13: ffffffffa01fff70 R14: 0000000000000000 R15: 0000000000000000
[    0.874934] FS:  00007f245a4798c0(0000) GS:ffff88001ee00000(0000) knlGS:0000000000000000
[    0.875962] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[    0.876699] CR2: 00007f245a48a000 CR3: 000000001d54c000 CR4: 00000000000406f0
[    0.877618] Call Trace:
[    0.877942]  mce_register_decode_chain+0x38/0x40
[    0.878548]  sbridge_init+0x313/0x1000 [sb_edac]
[    0.879132]  ? 0xffffffffa0225000
[    0.879578]  do_one_initcall+0x51/0x1b0
[    0.880078]  ? kmem_cache_alloc_trace+0x14b/0x1b0
[    0.880698]  do_init_module+0x60/0x1fa
[    0.881189]  load_module+0x1f31/0x2710
[    0.881687]  ? __symbol_put+0x60/0x60
[    0.882159]  ? security_kernel_post_read_file+0x6b/0x80
[    0.882834]  SYSC_finit_module+0xa6/0xf0
[    0.883335]  SyS_finit_module+0xe/0x10
[    0.883839]  entry_SYSCALL_64_fastpath+0x1a/0xa9
[    0.884428] RIP: 0033:0x7f2458eddc29
[    0.884894] RSP: 002b:00007fffbedf1368 EFLAGS: 00000246 ORIG_RAX: 0000000000000139
[    0.885857] RAX: ffffffffffffffda RBX: 00007f245a458d46 RCX: 00007f2458eddc29
[    0.886768] RDX: 0000000000000000 RSI: 00007f24597f8cf9 RDI: 0000000000000011
[    0.887671] RBP: 0000563bb063d8e0 R08: 0000000000000000 R09: 0000563bb0643800
[    0.888585] R10: 0000000000000011 R11: 0000000000000246 R12: 0000000000000001
[    0.889479] R13: 0000563bb064c4b0 R14: 0000000000000000 R15: 000000000000000b
[    0.890406] Code: 48 89 e5 41 54 49 89 f4 53 48 89 fb e8 49 e4 6d 00 48 8b 53 08 48 8d 4b 08 48 85 d2 74 20 45 8b 44 24 10 44 3b 42 10 7e 08 eb 13 <44> 39 42 10 7c 0d 48 8d 4a 08 48 8b 52 08 48 85 d2 75 ed 49 89 
[    0.892827] RIP: atomic_notifier_chain_register+0x31/0x60 RSP: ffffc9000034fc38
[    0.893765] ---[ end trace 28549cb879907588 ]---
[    0.894350] Kernel panic - not syncing: Fatal exception
[    0.895688] Kernel Offset: disabled
[    0.896152] Rebooting in 1 seconds..
libguestfs: error: appliance closed the connection unexpectedly, see earlier error messages
Comment 1 Richard W.M. Jones 2017-06-08 16:57:34 EDT
This is a duplicate of

  https://bugzilla.redhat.com/show_bug.cgi?id=1448312

However that's a private bug against RHEL 7 (for no real reason :-/)

It's a kernel bug and the fix for it is:

  https://marc.info/?l=linux-acpi&m=149506537617370&w=2

The fix is planned to be included in the RHEL 7.4 kernel when it
is released soon.

*** This bug has been marked as a duplicate of bug 1448312 ***
Comment 2 Richard W.M. Jones 2017-06-08 16:58:39 EDT
I've added you to the CC of the private bug, so you should be able
to see it (or most of it).  If you cannot get access even after logging
in, then let me know.

Note You need to log in before you can comment on or make changes to this bug.