Bug 1460072 - "rhevm-sdk-python" package is not available for RHEL7 workstation
"rhevm-sdk-python" package is not available for RHEL7 workstation
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-sdk-python (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity medium
: ovirt-4.2.0
: ---
Assigned To: Ondra Machacek
Pavol Brilla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-08 21:10 EDT by rakesh kumar
Modified: 2017-11-06 03:59 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-11-06 03:59:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Rel-Eng
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rakesh kumar 2017-06-08 21:10:42 EDT
Description of problem:
"rhevm-sdk-python" package is not available for a RHEL7 workstation but customer wants the same. I have raised a JIRA with release engineering but they have asked to create a Bugzilla for the same:

Service request with release engineering:
---
https://projects.engineering.redhat.com/browse/RCM-4238
---


Version-Release number of selected component (if applicable):
RHEL7.2 workstation 

How reproducible:
Always


Actual results: 
"rhevm-sdk-python" package is not available for RHEL7 workstation

Expected results:
"rhevm-sdk-python" package should be available

Additional info:
Comment 1 Martin Perina 2017-06-13 05:03:08 EDT
There is no such package provided by RHV, here are correct package names for RHV Python SDK:

 python-ovirt-engine-sdk4
   - provides Python SDK v4

 ovirt-engine-sdk-python
   - provides Python SDK v3
Comment 2 rakesh kumar 2017-06-13 05:06:16 EDT
Hi,

As per the following document, "rhevm-sdk-python" package should be available for RHEL7 workstation:
—
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html/Python_SDK_Guide/chap-Overview.html#Python_SDK_Prerequisites
Comment 3 Ondra Machacek 2017-06-20 08:53:59 EDT
For 3.6 there should be package rhevm-sdk-python, but for RHV 4.0, there is  ovirt-engine-sdk-python, which version do you use?
Comment 4 rakesh kumar 2017-06-20 20:52:23 EDT
@Ondra Machacek, the customer using RHEVM-3.6
Comment 5 Ondra Machacek 2017-06-27 08:18:49 EDT
Is the machine subscribed to the RHV channel? This package is not provided by rhel7 channels.
Comment 21 errata-xmlrpc 2017-11-06 03:59:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3118

Note You need to log in before you can comment on or make changes to this bug.