Bug 1460094 - registry.fedoraproject.org/fedora:25 is some ancient image which does not have /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-25-x86_64
registry.fedoraproject.org/fedora:25 is some ancient image which does not hav...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: docker (Show other bugs)
25
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Frantisek Kluknavsky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-09 02:05 EDT by Jan Pazdziora
Modified: 2017-06-09 09:51 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-09 09:51:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2017-06-09 02:05:20 EDT
Description of problem:

Up until yesterday, installing packages with RUN in Dockerfile which uses FROM registry.fedoraproject.org/fedora:25 worked. Now things fail as can also be demonstrated with plaing docker run:

$ docker run --rm -ti registry.fedoraproject.org/fedora:25 dnf install -y python
Fedora 25 - x86_64 - Updates                                                                                                          78 MB/s |  23 MB     00:00    
Fedora 25 - x86_64 - Test Updates                                                                                                     38 MB/s | 2.3 MB     00:00    
Fedora 25 - x86_64                                                                                                                    83 MB/s |  50 MB     00:00    
Last metadata expiration check: 0:00:12 ago on Fri Jun  9 06:01:14 2017.
Dependencies resolved.
=====================================================================================================================================================================
 Package                                       Arch                              Version                                    Repository                          Size
=====================================================================================================================================================================
Installing:
 python                                        x86_64                            2.7.13-2.fc25                              updates                             96 k
 python-libs                                   x86_64                            2.7.13-2.fc25                              updates                            6.2 M
 python-pip                                    noarch                            8.1.2-2.fc25                               fedora                             1.7 M
 python2-setuptools                            noarch                            25.1.1-1.fc25                              fedora                             506 k

Transaction Summary
=====================================================================================================================================================================
Install  4 Packages

Total download size: 8.5 M
Installed size: 34 M
Downloading Packages:
(1/4): python-2.7.13-2.fc25.x86_64.rpm                                                                                               793 kB/s |  96 kB     00:00    
(2/4): python2-setuptools-25.1.1-1.fc25.noarch.rpm                                                                                    20 MB/s | 506 kB     00:00    
(3/4): python-pip-8.1.2-2.fc25.noarch.rpm                                                                                             10 MB/s | 1.7 MB     00:00    
(4/4): python-libs-2.7.13-2.fc25.x86_64.rpm                                                                                           28 MB/s | 6.2 MB     00:00    
---------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                4.5 MB/s | 8.5 MB     00:01     
warning: /var/cache/dnf/updates-87ad44ec2dc11249/packages/python-2.7.13-2.fc25.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID fdb19c98: NOKEY
Curl error (37): Couldn't read a file:// file for file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-25-x86_64 [Couldn't open file /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-25-x86_64]
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
$ 

The reason seems to be the missing /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-25-x86_64.

Version-Release number of selected component (if applicable):

registry.fedoraproject.org/fedora:25 f3535ce68198

How reproducible:

Deterministic.

Steps to Reproduce:
1. docker run --rm -ti registry.fedoraproject.org/fedora:25 ls -la /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-25-x86_64

Actual results:

$ docker run --rm -ti registry.fedoraproject.org/fedora:25 ls -la /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-25-x86_64
ls: cannot access '/etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-25-x86_64': No such file or directory

Expected results:

lrwxrwxrwx. 1 root root 29 Mar  6 18:52 /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-25-x86_64 -> RPM-GPG-KEY-fedora-25-primary

This is the result I get with

$ docker run --rm -ti fedora:25 ls -la /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-25-x86_64

Additional info:

The registry.fedoraproject.org/fedora:25 is fresh from today's update yet it says

$ docker images | grep registry.fedoraproject.org/fedora
registry.fedoraproject.org/fedora   25                  f3535ce68198        10 months ago       193.8 MB

To the contrary the docker.io/fedora:25 is fresh one

docker.io/fedora                    25                  15895ef0b3b2        6 weeks ago         230.9 MB

and works.

I first saw it reported in bug 1415167.
Comment 1 Jan Pazdziora 2017-06-09 02:06:54 EDT
Filing against docker as I have no idea what component should be used for tracking issues with broken images.
Comment 2 Jan Pazdziora 2017-06-09 02:17:54 EDT
The

registry.fedoraproject.org/fedora   25                  6c0c98f53e1e        2 weeks ago         231.9 MB

was a good one.
Comment 3 Daniel Walsh 2017-06-09 07:34:46 EDT
Franticek can you update or remove this image?
Comment 4 Colin Walters 2017-06-09 09:44:47 EDT
This is breaking a lot of our CI in Project Atomic (PAPR); see the failed tasks in
https://github.com/projectatomic/rpm-ostree/pull/825
Comment 5 Adam Miller 2017-06-09 09:51:09 EDT
Fixed. Aplogies, I specified the wrong koji tag in a sync script for the latest image. If there are any further issues, please let me know.

Note You need to log in before you can comment on or make changes to this bug.