Bug 1460122 - [trello aeh71wF7] Save/Create/Cancel buttons on many edit/create pages wrongly give "unsaved" prompt
[trello aeh71wF7] Save/Create/Cancel buttons on many edit/create pages wrongl...
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Samuel Padgett
Depends On:
  Show dependency treegraph
Reported: 2017-06-09 03:53 EDT by Xingxing Xia
Modified: 2017-08-16 15 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2017-06-21 08:14:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
one_reproducing_example_prompt_after_clicking_Create_in_createroute_page (136.80 KB, image/png)
2017-06-09 09:47 EDT, Xingxing Xia
no flags Details

  None (edit)
Description Xingxing Xia 2017-06-09 03:53:44 EDT
Description of problem:
Save/Create buttons on some edit/create pages wrongly give "unsaved" prompt.
A few pages don't reproduce, though.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Create project, create resources
$ oc new-app -f https://raw.githubusercontent.com/openshift/origin/master/examples/sample-app/application-template-stibuild.json
2. In web console, create route:
Applications --> Routes --> Create Route
--> fill in Name, Service --> click Create button
3.In web console DC page, Actions --> Add/Edit Autoscaler
--> fill in params --> click Save button
4. Check other Create/Save buttons in create secret page, edit configmap page etc.

Actual results:
Steps 2, 3 and 4: prompt "You have unsaved changes. Leave this page anyway?".
Clicking Cancel, the mouse turns to look like an forbidden icon.
No matter clicking Cancel or OK, the resource unexpectedly is created/saved.

Expected results:
Steps 2, 3 and 4: should not prompt, because when clicking Create/Save, user definitely wants to create/save, rather than carelessly jump to somewhere.

Additional info:
This makes automated web cases fail, so severity chooses High.
Some page, e.g. create configmap page does not prompt, though
Comment 1 Samuel Padgett 2017-06-09 08:09:14 EDT
> This makes automated web cases fail, so severity chooses High.

I can't reproduce these problems. Are these only happening in your automated tests? I suspect your automation is leaving the page before it has finished processing.
Comment 2 Samuel Padgett 2017-06-09 08:23:16 EDT
If the test clicks Save and immediately changes the browser URL, it will likely cause this. We set a done editing flag after we get a successful POST response from the server. If the URL changes while the request is still in flight, you would get the prompt.
Comment 4 Xingxing Xia 2017-06-09 09:44:58 EDT
Thank you.
> Are these only happening in your automated tests?
Not only. The issue was first found in automated tests against the free-int (v3.6.100) testing scheduled today, then we tried manual tests and tried as multiple pages as possible and finally determined the bug.

> I can't reproduce these problems
> ... We set a done editing flag ...
Not sure if you mean the commit in https://bugzilla.redhat.com/show_bug.cgi?id=1459848#c3 would fix this bug? Today as of the testing, latest puddle was v3.6.100 which does not include that commit, so we were not able to have env to test that commit.

Currently free-int version is still v3.6.100, could you have a try? I just tried again and uploading the attachment
Comment 5 Xingxing Xia 2017-06-09 09:47 EDT
Created attachment 1286421 [details]
Comment 7 shahan 2017-06-16 00:48:07 EDT
I checked this issue on openshift v3.6.109, it has been fixed. Please change the bug to ON_QA, so that I can verify the bug. Thanks!
Comment 8 shahan 2017-06-18 23:17:32 EDT
Checked this issue, it was fixed. Now change the status to Verified.

Note You need to log in before you can comment on or make changes to this bug.