Bug 1460161 - lvs reports incorrect output when a snapshot is merging
lvs reports incorrect output when a snapshot is merging
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2 (Show other bugs)
7.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Zdenek Kabelac
cluster-qe@redhat.com
: Regression
Depends On: 1458061
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-09 05:48 EDT by Alasdair Kergon
Modified: 2017-08-01 17:54 EDT (History)
12 users (show)

See Also:
Fixed In Version: lvm2-2.02.171-5.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1458061
Environment:
Last Closed: 2017-08-01 17:54:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2222 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2017-08-01 14:42:41 EDT

  None (edit)
Description Alasdair Kergon 2017-06-09 05:48:38 EDT
+++ This bug was initially created as a clone of Bug #1458061 +++

lvs -a -o+name
  LV   
  lvol0
  [lvol1]

lvs -a -o+name,attr
  LV    Attr      
  lvol0 Owi-a-s---
  lvol0 Owi-a-s---

The output changes according to which columns you select!

Due to this commit which incorrectly overwrites the LV being reported upon when kernel device-mapper status information is queried:

commit 6fd20be629b6dceb96702c5f875a2e612e6f465d
Author: Zdenek Kabelac <zkabelac@redhat.com>
Date:   Mon Dec 5 14:31:25 2016 +0100

    activation: lv_info_with_seg_status API change
    
    Drop LV from passed API arg - it's always segment being checked.
    Also use_layer is now in full control of lv_info_with_seg_status().
    It decides which device needs to be checked to get 'the most info'.
    
    TODO: future version should be able to expose status from


Sometimes the status comes from a different LV from the rest of the data - it is incorrect to change it affecting the caller!

-                       lv = origin_from_cow(lv);
+                       status->lv = lv = origin_from_cow(lv);
Comment 1 Zdenek Kabelac 2017-06-09 16:18:34 EDT
Restoring some reported info for old snapshot with:

https://www.redhat.com/archives/lvm-devel/2017-June/msg00027.html
Comment 5 errata-xmlrpc 2017-08-01 17:54:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2222

Note You need to log in before you can comment on or make changes to this bug.