Bug 1460196 - Build RPM of latest release
Build RPM of latest release
Status: NEW
Product: Fedora
Classification: Fedora
Component: slic3r-prusa3d (Show other bugs)
28
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-09 06:59 EDT by Tom Georgoulias
Modified: 2018-02-20 10:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Georgoulias 2017-06-09 06:59:43 EDT
Description of problem:
Newest version of slic3r-prusa3d has a lot of bug fixes, can an RPM be built to replace the current 1.33.2 version included with Fedora 25?

Version-Release number of selected component (if applicable):
1.35.2

How reproducible:


Steps to Reproduce:
NA

Actual results:


Expected results:


Additional info:
https://github.com/prusa3d/Slic3r/releases
Comment 1 Miro Hrončok 2017-06-11 15:53:06 EDT
I had troubles with wxPython https://github.com/prusa3d/Slic3r/issues/225

Since then I haven't got time to look at that any closer. Any help would really be appreciated.
Comment 2 Tom Georgoulias 2017-06-16 19:55:20 EDT
Would that be help with getting the perl-Alien-wxWidgets RPM updated with the missing dep?
Comment 3 Miro Hrončok 2017-06-18 16:38:45 EDT
I don't think it is a missing dependency problem. But getting perl-Alien-wxWidgets work with GTK3 would definitely help.
Comment 4 Jason Tibbitts 2017-10-09 23:07:44 EDT
It appears that perl-Alien-wxWidgets has since been updated, at least in rawhide (but not F26).  This new release does include the Config/gtk_3_0_3_uni_gcc_3_4.pm file which at least has some chance of helping.  I'm trying to set up some builds now.  (I'm just getting into 3D printing and trying to get my tools set up.)
Comment 5 Miro Hrončok 2017-10-10 10:51:44 EDT
Dennis Gilmore has a somehow buildable new version. He was informing me about his progress on #fedora-3Dprinting IRC, but I was unable to have a look at it closer since due to other things and deadlines.
Comment 6 Petr Pisar 2017-11-01 11:31:30 EDT
Dennis forgot to upload the version_1.37.1.tar.gz source archive into Fedora's look-aside cache:

$ fedpkg sources
Downloading version_1.37.1.tar.gz
######################################################################## 100.0%
Remove downloaded invalid file ./version_1.37.1.tar.gz
Could not execute sources: Server returned status code 404

The sources checksum matches the file from Source0 URL. Please review the archive for used licenses and upload it into Fedora.

This bug prevents from building this package.
Comment 7 Miro Hrončok 2017-11-02 06:02:28 EDT
I wasn't aware Denis is actually pushing to dist git. Denis, does it build and work, were you able to finish?
Comment 8 Fedora End Of Life 2017-11-16 13:45:18 EST
This message is a reminder that Fedora 25 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 25. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '25'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 25 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.
Comment 9 Miro Hrončok 2017-11-18 10:17:25 EST
Dennis?
Comment 10 Dennis Gilmore 2018-01-17 12:37:59 EST
gahh sorry, behind in bugs,  the perlWX stack has a bunch of bugs in how its built, I need to get with the owner of that stack to get it fixed. the end result is that it builds but does not run.
Comment 11 Fedora End Of Life 2018-02-20 10:28:16 EST
This bug appears to have been reported against 'rawhide' during the Fedora 28 development cycle.
Changing version to '28'.

Note You need to log in before you can comment on or make changes to this bug.