Bug 1460233 - [3.4] Docker MTU is wrong when SDN is adjusted to smaller MTU
[3.4] Docker MTU is wrong when SDN is adjusted to smaller MTU
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.4.0
x86_64 Linux
unspecified Severity high
: ---
: 3.4.z
Assigned To: Scott Dodson
Johnny Liu
:
Depends On: 1457062 1460235
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-09 08:38 EDT by Scott Dodson
Modified: 2017-06-29 09:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Starting with OCP 3.4, OpenShift's SDN plugins no longer reconfigure the docker bridge MTU, rather pods are configured properly on creation. Because of this change, non-OpenShift containers may have an MTU configured that is too large to allow access to hosts on the SDN. The installer has been updated to align the MTU setting for the docker bridge with the MTU used inside the cluster, thus avoiding the problem.
Story Points: ---
Clone Of: 1457062
Environment:
Last Closed: 2017-06-29 09:33:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Johnny Liu 2017-06-26 23:31:46 EDT
Verified this bug with openshift-ansible-3.4.108-1.git.0.6b32ddc.el7.noarch, and PASS.

[root@ip-172-18-5-41 ~]# cat /etc/sysconfig/docker-network
# /etc/sysconfig/docker-network
DOCKER_NETWORK_OPTIONS=' --mtu=8951'
[root@ip-172-18-5-41 ~]# grep -i mtu /etc/origin/node/node-config.yaml 
   mtu: 8951
Comment 5 errata-xmlrpc 2017-06-29 09:33:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1666

Note You need to log in before you can comment on or make changes to this bug.