Bug 1460239 - [RFE] Add interface button to run "puppet cert re-inventory"
[RFE] Add interface button to run "puppet cert re-inventory"
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Puppet (Show other bugs)
6.3.0
x86_64 Linux
low Severity low (vote)
: Unspecified
: 6.X
Assigned To: satellite6-bugs
Katello QA List
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-09 08:56 EDT by Marc Richter
Modified: 2017-10-05 13:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-10-05 13:25:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 20685 None None None 2017-08-22 03:57 EDT

  None (edit)
Description Marc Richter 2017-06-09 08:56:42 EDT
Description of problem:
When revoking puppet certs, they stay in the inventory database. While this may be the intended behavior, too many dead certs clutter the display. Users can run "puppet cert re-inventory" from the command line to forcibly clean this up, but it would be nice to add a button on the Capsules / Puppet CA tab to simply run this command

Version-Release number of selected component (if applicable):
6.3.x
Comment 2 Ondřej Pražák 2017-08-22 03:57:38 EDT
Created redmine issue http://projects.theforeman.org/issues/20685 from this bug
Comment 3 Bryan Kearney 2017-10-05 13:25:44 EDT
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in product in the forseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.

Note You need to log in before you can comment on or make changes to this bug.