Bug 1460278 - should be possible to use a client key vs admin key for ceph integration with openshift
should be possible to use a client key vs admin key for ceph integration with...
Status: CLOSED DUPLICATE of bug 1460277
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage (Show other bugs)
3.5.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bradley Childs
Jianwei Hou
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-09 10:38 EDT by Ruchika K
Modified: 2017-06-09 10:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-09 10:41:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ruchika K 2017-06-09 10:38:47 EDT
Description of problem:
s per the documentation here: https://access.redhat.com/documentation/en-us/openshift_container_platform/3.5/html-single/installation_and_configuration/#using-ceph-rbd-installing-the-ceph-common-package
it appears the ceph admin key MUST be used.
Why is this the case ?
Shouldn't it be possible to assign a client and use a particular client key for the ceph rbd ?


Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:

Master Log:

Node Log (of failed PODs):

PV Dump:

PVC Dump:

StorageClass Dump (if StorageClass used by PV/PVC):

Additional info:
Comment 1 Ruchika K 2017-06-09 10:41:17 EDT

*** This bug has been marked as a duplicate of bug 1460277 ***

Note You need to log in before you can comment on or make changes to this bug.