Bug 1460328 - Intermittent 503s after scaling routers
Intermittent 503s after scaling routers
Status: CLOSED DUPLICATE of bug 1451854
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing (Show other bugs)
3.4.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Bennett
zhaozhanqi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-09 13:51 EDT by Brennan Vincello
Modified: 2017-06-20 14:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-20 14:47:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brennan Vincello 2017-06-09 13:51:41 EDT
Description of problem:

When deploying more than one 3.4.1.18 router, occasional 503s are observed.

Version-Release number of selected component (if applicable): OCP 3.4.1

How reproducible: Intermittent

Steps to Reproduce:
1. Scale router from 1 to 2
2. Monitor routes with a curl loop

Actual results: Occasional 503s observed

Expected results: No 503s

Additional info:

ROUTE: routeinfra0d Thu Jun  1 09:04:30 EDT 2017 Failed while loading URL with a 503 on attempt 53
ROUTE: routeinfra1d Thu Jun  1 09:04:30 EDT 2017 Failed while loading URL with a 503 on attempt 53
ROUTE: routeinfra0d Thu Jun  1 09:04:31 EDT 2017 Found a 200 on attempt 54
ROUTE: routeinfra1d Thu Jun  1 09:04:31 EDT 2017 Found a 200 on attempt 54
ROUTE: routeinfra0d Thu Jun  1 09:06:11 EDT 2017 Failed while loading URL with a 503 on attempt 1
ROUTE: routeinfra1d Thu Jun  1 09:06:11 EDT 2017 Failed while loading URL with a 503 on attempt 1
(snip) 
ROUTE: routeinfra0d Thu Jun  1 09:07:04 EDT 2017 Failed while loading URL with a 503 on attempt 40
ROUTE: routeinfra1d Thu Jun  1 09:07:04 EDT 2017 Failed while loading URL with a 503 on attempt 40
ROUTE: routeinfra0d Thu Jun  1 09:07:05 EDT 2017 Found a 200 on attempt 41
ROUTE: routeinfra1d Thu Jun  1 09:07:05 EDT 2017 Found a 200 on attempt 41

Attempts to correlate router log timestamps (with reloads) have not been successful yet.
Comment 2 Ben Bennett 2017-06-20 14:47:48 EDT

*** This bug has been marked as a duplicate of bug 1451854 ***

Note You need to log in before you can comment on or make changes to this bug.