Bug 146033 - RHR2 net test fails with "Connection reset by peer"
RHR2 net test fails with "Connection reset by peer"
Status: CLOSED NOTABUG
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: net (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Rob Landry
Rob Landry
:
Depends On:
Blocks: 143442
  Show dependency treegraph
 
Reported: 2005-01-24 15:30 EST by Daniel W. Ottey
Modified: 2007-04-18 13:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-28 08:47:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
NETWORK/output.log (3.54 KB, text/plain)
2005-01-24 15:30 EST, Daniel W. Ottey
no flags Details
NETWORK/hardware.log (697 bytes, text/plain)
2005-01-24 15:30 EST, Daniel W. Ottey
no flags Details
output.log from e100 (PASS) and e1000 (FAIL) (44.82 KB, text/plain)
2005-01-26 11:45 EST, Daniel W. Ottey
no flags Details
hardware.log from e100 (PASS) and e1000 (FAIL) (700 bytes, text/plain)
2005-01-26 11:47 EST, Daniel W. Ottey
no flags Details

  None (edit)
Description Daniel W. Ottey 2005-01-24 15:30:17 EST
Description of problem:
RHR2 net test fails with "Connection reset by peer"

It looks to me like the SSH connection is what is failing, but I cannot
determine why.

Version-Release number of selected component (if applicable):
rhr2-rhel4-1.0-10

How reproducible:
Everytime

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Test fails

Expected results:
Test passes

Additional info:
Failure is reproducable both with a static and a DHCP ip address.
Comment 1 Daniel W. Ottey 2005-01-24 15:30:18 EST
Created attachment 110155 [details]
NETWORK/output.log
Comment 2 Daniel W. Ottey 2005-01-24 15:30:51 EST
Created attachment 110156 [details]
NETWORK/hardware.log
Comment 3 Daniel W. Ottey 2005-01-25 12:11:51 EST
Raising severity to HIGH.  I tried to find a severity of BLOCKER, because this
is blocking our ability to certify the hardware, but that severity is not in the
list.

An issue tracker will be opened shortly.
Comment 4 Richard Li 2005-01-25 13:04:59 EST
What version of RHEL are you running on the iSpec server?

This may be the same as bug 145570. Can you try the change described in that
ticket (change the ab parameters) and see if that addresses the problem?
Comment 5 Daniel W. Ottey 2005-01-25 14:09:48 EST
The iSpec server is running RHEL4 prec-RC2.  We can upgrade it if need be, but
we looked at the RPM versions of both Apache and SSH between the pre-rc2 and the
final and couldn't find any difference.

We will test the work-around by modifying the 'ab' command in
/usr/share/rhr/tests/network/tcp as suggested in bug 145570.
Comment 6 Richard Li 2005-01-25 14:11:50 EST
I agree; I do not think that upgrading the iSpec server will change anything.
Let us know how the ab change goes.
Comment 7 Daniel W. Ottey 2005-01-26 11:44:23 EST
I am sorry to report that the ab change did not help us.  We are still receiving
the "Connection reset by peer" error.

We've now run the test against an Integrated e100 NIC and that one passes (but
for some reasons its name is dev6536 and not ethx).  But the test still fails
when run against our gigabit Intel controllers which use the e1000 driver.

I will post a new log file set shortyl.
Comment 8 Daniel W. Ottey 2005-01-26 11:45:40 EST
Created attachment 110252 [details]
output.log from e100 (PASS) and e1000 (FAIL)
Comment 9 Daniel W. Ottey 2005-01-26 11:47:08 EST
Created attachment 110253 [details]
hardware.log from e100 (PASS) and e1000 (FAIL)
Comment 10 Rob Landry 2005-01-26 11:59:59 EST
Can the ab line be run by hand against the e1000 NIC and pass or does that
always fail?
Comment 11 Daniel W. Ottey 2005-01-28 08:47:07 EST
Yes, the ab command was able to pass "by hand" against the e1000 NIC.  This was
by running it from the ispec server and not through an SSH command.

I believe the SSH was timing out.

A good reason for this is that while our SUT had a gigabit connection, the ispec
server did not.  So ab was downloading a 125MB file over a 100mbit connetion. 
It would take atleast 15 minutes for text "Processed 100 Requests" to be
displayed to the screen.  I think the lack of interaction (display and typing)
caused the SSH connection to time out.

We have since moved ispec to a newer server that supports gigabit.  We rerun the
 test and it passes as expected.

Thak you for all your help, and I apologize for our error when setting up our
environment.

Note You need to log in before you can comment on or make changes to this bug.