Bug 1460379 - libdb update to libdb-5.3.28-21 causes rpm and dnf segfault
libdb update to libdb-5.3.28-21 causes rpm and dnf segfault
Status: CLOSED DUPLICATE of bug 1460303
Product: Fedora
Classification: Fedora
Component: libdb (Show other bugs)
25
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Petr Kubat
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-09 17:39 EDT by Chris Caudle
Modified: 2017-06-09 19:26 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-09 19:26:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Caudle 2017-06-09 17:39:20 EDT
Description of problem: Ran dnf to update new packages.  Found libdb-5.3.28-21 as an available update, but after upgrade rpm and dnf crash with error in Berkely DB library.


Version-Release number of selected component (if applicable): 5.3.28-21


How reproducible: RPM and dnf crash every time now when run sudo or under su. Can run as normal user, but cannot update packages from my normal user account.  Occurred on two separate systems which were updating simultaneously.


Steps to Reproduce:
1. dnf upgrade libdb libdb-utils
2. sudo dnf check-update 
3. error: rpmdb: BDB0113 Thread/process 14829/140660169317184 failed: BDB1507 Thread died in Berkeley DB library

Actual results:
rpm crashes in Berkeley DB

Expected results:
rpm database is still accessible

Additional info:
Comment 1 Chris Caudle 2017-06-09 18:23:55 EDT
I was able to recover with sudo rpm --rebuilddb, so the severity of the bug can be reduced.
Comment 2 Adam Williamson 2017-06-09 19:26:36 EDT

*** This bug has been marked as a duplicate of bug 1460303 ***

Note You need to log in before you can comment on or make changes to this bug.