Bug 1460402 - libreswan mistakenly does not allow repeated CERT / CERTREQ payloads in IKEv2
libreswan mistakenly does not allow repeated CERT / CERTREQ payloads in IKEv2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libreswan (Show other bugs)
7.3
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Paul Wouters
Ondrej Moriš
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-09 18:59 EDT by Paul Wouters
Modified: 2017-08-01 08:31 EDT (History)
7 users (show)

See Also:
Fixed In Version: 3.20-2
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 08:31:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Wouters 2017-06-09 18:59:07 EDT
Description of problem:

"tunnel-XXXX" #768: payload (ISAKMP_NEXT_v2CERT) unexpectedly repeated. Message dropped.

This affects all versions of libreswan up to 3.18, so RHEL-7.3 packages have this issue as well. All versions of openswan are affected as well.

The current (prerelease) build for RHEL-7.4 which is based on 3.20 contains the fix for this issue.
Comment 1 Paul Wouters 2017-06-09 19:00:57 EDT
The code change is in ikev2.c:

Old code:

static const lset_t repeatable_payloads = P(N) | P(D) | P(CP) | P(V); 

New code:

static const lset_t repeatable_payloads = P(N) | P(D) | P(CP) | P(V) | P(CERT) | P(CERTREQ);
Comment 10 Ondrej Moriš 2017-06-22 03:38:57 EDT
Cannot reproduce this issue. Verified SanityOnly with libreswan-3.20-3.el7.
Comment 11 errata-xmlrpc 2017-08-01 08:31:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2101

Note You need to log in before you can comment on or make changes to this bug.