Bug 1460445 - pkg_resources.DistributionNotFound: The 'Sphinx' distribution was not found and is required by enki
pkg_resources.DistributionNotFound: The 'Sphinx' distribution was not found a...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: enki (Show other bugs)
26
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Raphael Groner
Fedora Extras Quality Assurance
:
: 1482831 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-10 13:28 EDT by Raphael Groner
Modified: 2017-08-23 02:06 EDT (History)
2 users (show)

See Also:
Fixed In Version: enki-17.03.0-6.fc26 enki-17.03.0-6.fc25
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-22 16:41:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raphael Groner 2017-06-10 13:28:34 EDT
Description of problem:
Enki does not work without installed sphinx.

Version-Release number of selected component (if applicable):
enki-17.03.0-4.fc26.noarch

How reproducible:
yes

Steps to Reproduce:
1. dnf remove python3-sphinx
2. dnf install enki
3. try to start enki

Actual results:
Traceback (most recent call last):
  File "/usr/bin/enki", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3036, in <module>
    @_call_aside
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3020, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3049, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 654, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 968, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 854, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'Sphinx' distribution was not found and is required by enki

Expected results:
enki works.

Additional info:
Possible fix: dnf install python3-enki
Comment 1 Raphael Groner 2017-06-19 15:33:33 EDT
Additional info:
Possible fix: dnf install python3-sphix

… of course. Damn typos.
Comment 2 Raphael Groner 2017-06-19 15:34:05 EDT
Possible fix: dnf install python3-sphinx
Comment 3 Fedora Update System 2017-08-13 17:58:13 EDT
enki-17.03.0-6.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-bd3f078ebf
Comment 4 Fedora Update System 2017-08-14 23:49:55 EDT
enki-17.03.0-6.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-bd3f078ebf
Comment 5 Fedora Update System 2017-08-15 02:22:50 EDT
enki-17.03.0-6.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-33f68f4071
Comment 6 Raphael Groner 2017-08-18 14:48:58 EDT
*** Bug 1482831 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2017-08-22 16:41:05 EDT
enki-17.03.0-6.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2017-08-23 02:06:53 EDT
enki-17.03.0-6.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.