Bug 1460519 - Origin shows RHV after import of VM with unknown origin
Summary: Origin shows RHV after import of VM with unknown origin
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.1.2
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: ---
: ---
Assignee: Nobody
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs 1459816
TreeView+ depends on / blocked
 
Reported: 2017-06-11 19:32 UTC by Tomáš Golembiovský
Modified: 2018-11-21 00:08 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-21 00:08:12 UTC
oVirt Team: Virt


Attachments (Terms of Use)
screenshot (84.30 KB, image/png)
2018-04-27 02:42 UTC, mxie@redhat.com
no flags Details

Description Tomáš Golembiovský 2017-06-11 19:32:51 UTC
Description of problem:

When importing VM by virt-v2v (either from OVA or via export-domain) that has no Origin specified the import dialog shows correctly 'Origin' as 'N/A'. But after import is finished the VM has it's origin specified as 'RHV'. That is because there is no special value for 'N/A' in the engine code.


Version-Release number of selected component (if applicable):
oVirt 4.1.2


How reproducible:
100%

Steps to Reproduce:
1. Import VM disk image to export domain using: virt-v2v -i disk -o rhev ...
2. Import the VM from export domain


Actual results:

Origin shows 'RHV'


Expected results:

Origin should be 'N/A' or something more appropriate.

Comment 1 Tomas Jelinek 2017-06-12 14:26:56 UTC
The reason that the origin is RHV is that in case the origin is not set, engine looks the value up from engine config (key: OriginType).

The actually correct solution would be to enrich the OriginType enum by the N/A option and explicitly pass this one from frontend to store it.

But this is only a cosmetic issue.

Comment 2 mxie@redhat.com 2018-04-27 02:41:43 UTC
I can reproduce the bug on rhv4.2

Description of problem:
Original info is wrong if import guest from ova file on rhv4.2 GUI

Version-Release number of selected component (if applicable):
ovirt-engine-4.2.3.2-0.1.el7.noarch
vdsm-4.20.26-1.el7ev.x86_64


How reproducible:
100%

Steps to Reproduce:
1.Copy ova file to host which is registered on rhv4.2
2.Import guest from ova on rhv4.2
3.Found guest's original info is RHV after importing, pls refer to screenshot


Actual results:
As above description

Expected results:
Original info should be VMware if import guest from ova file on rhv4.2 GUI

Additional info:

Comment 3 mxie@redhat.com 2018-04-27 02:42:50 UTC
Created attachment 1427445 [details]
screenshot

Comment 4 Ryan Barry 2018-11-21 00:08:12 UTC
Closing because this is cosmetic only with an easy workaround


Note You need to log in before you can comment on or make changes to this bug.