Bug 1460589 - [WALA] deprovision is executed even if input 'n'
[WALA] deprovision is executed even if input 'n'
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: WALinuxAgent (Show other bugs)
6.10
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Vitaly Kuznetsov
Virtualization Bugs
: Extras
Depends On: 1451174 1460588
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-12 02:29 EDT by yuxisun@redhat.com
Modified: 2017-07-24 05:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1460588
Environment:
Last Closed: 2017-07-24 05:32:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Github Azure/WALinuxAgent/issues/757 None None None 2017-06-12 02:29 EDT

  None (edit)
Description yuxisun@redhat.com 2017-06-12 02:29:47 EDT
+++ This bug was initially created as a clone of Bug #1460588 +++

Description of problem:
When we run "waagent -deprovision" and input "n" at the confirmation, the deprovisioning is still executed.

Version-Release number of selected component (if applicable):
WALinuxAgent-2.2.12-1

RHEL Version:
RHEL-7.4/6.9

How reproducible:
100%

Steps to Reproduce:
1. Prepare a running VM in Azure.
2. Ssh login. Run "waagent -deprovision" and input "n" and "Enter" at the confirmation(Do you want to proceed (y/n)n)

Actual results:
The deprovisioning is still executed.

Expected results:
The deprovisioning is not executed.

Additional info:
1. The root cause is in pa/deprovision/default.py Line#220, the return value of self.do_confirmation(force=force) is not used. So that no matter what we input, it will go on deprovisioning.

--- Additional comment from Red Hat Bugzilla Rules Engine on 2017-06-12 02:28:29 EDT ---

Since this bug report was entered in Red Hat Bugzilla, the release flag has been set to ? to ensure that it is properly evaluated for this release.
Comment 2 Mohammed Gamal 2017-06-23 04:54:00 EDT
Fixed in v2.2.14
Comment 3 yuxisun@redhat.com 2017-06-26 05:45:08 EDT
Verify in WALinuxAgent-2.2.14-1.el6
RHEL version: RHEL-6.9-ondemand image
Result: Pass
Steps: As description
Comment 4 yuxisun@redhat.com 2017-07-24 05:32:23 EDT
Close this issue because WALinuxAgent-2.2.14-1.el7/6 has shipped.

Note You need to log in before you can comment on or make changes to this bug.