Bug 1460614 - The page "Virtual Machines" has no response on Cockpit
The page "Virtual Machines" has no response on Cockpit
Status: CLOSED CURRENTRELEASE
Product: cockpit-ovirt
Classification: oVirt
Component: VDSM (Show other bugs)
0.10.7-0.0.6
Unspecified Unspecified
unspecified Severity urgent
: ovirt-4.1.5
: 0.10.7-0.0.22
Assigned To: Marek Libra
jianwu
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-12 04:23 EDT by jianwu
Modified: 2017-08-23 04:03 EDT (History)
13 users (show)

See Also:
Fixed In Version: cockpit-ovirt-0.10.7-0.0.22
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-23 04:03:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
rule-engine: blocker+
cshao: testing_ack+


Attachments (Terms of Use)
the picture for this bug (48.83 KB, image/png)
2017-06-12 04:23 EDT, jianwu
no flags Details
Bug log (9.18 MB, application/x-gzip)
2017-06-12 04:24 EDT, jianwu
no flags Details
web-console log (32.61 KB, text/plain)
2017-07-27 04:23 EDT, jianwu
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 78168 master MERGED vdsm: Fix import of D3 2017-06-15 02:40 EDT
oVirt gerrit 78169 ovirt-4.1 MERGED vdsm: Fix import of D3 2017-06-15 02:41 EDT
oVirt gerrit 79196 master MERGED vdsm: Fix production build for recent D3 vs. webpack's UglifyJSPlugin 2017-07-10 03:53 EDT
oVirt gerrit 79197 ovirt-4.1 MERGED vdsm: Fix production build for recent D3 vs. webpack's UglifyJSPlugin 2017-07-10 04:24 EDT

  None (edit)
Description jianwu 2017-06-12 04:23:09 EDT
Created attachment 1286967 [details]
the picture for this bug

Description of problem:
Select "Virtual Machines" tab under " Virtualization " page, the page has no response and when click any tabs, they could not function normally

Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.1-20170609.0
cockpit-ovirt-dashboard-0.10.7-0.0.19.el7ev.noarch
kernel-3.10.0-514.21.1.el7.x86_64

How reproducible:
100% 

Steps to Reproduce:
1. Install redhat-virtualization-host-4.1-20170609.0
2. Register to engine and setup VM
3. Login to cockpit via ip:9090
4. Come to " Virtualization " page and select "Virtual Machines" tab
5. Check its status

Actual results:
After step 5, the page "Virtual Machines" is down and has no response

Expected results:
After step 5, the page "Virtual Machines" could work normally and could check its information

Additional info:
The same issue in Firefox and Chrome browser
Comment 1 jianwu 2017-06-12 04:24 EDT
Created attachment 1286968 [details]
Bug log
Comment 2 jianwu 2017-06-12 05:19:39 EDT
Hi,
Because of this issue, we could not check VMs status and VMs' function via cockpit, for example,  if VMs behave correctly and if could shutdown the VM via cockpit. So, VMs test on cockpit are blocked.
Comment 3 Marek Libra 2017-06-14 06:45:02 EDT
External D3 JS library has changed API. Provided patch adapts our code to the new way of importing it.

Good to note: Code base of the "Virtual Machines" has not been changed for long time since it's deprecating in favor of Cockpit upstream development (see cockpit-machines and cockpit-machines-ovirt-provider).
Comment 4 Red Hat Bugzilla Rules Engine 2017-06-15 07:23:37 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 5 Yihui Zhao 2017-07-03 23:35:28 EDT
Also met the issue.

Version-Release number of selected component (if applicable):
rhvh-4.1-0.20170629.0+1
cockpit-storaged-135-4.el7.noarch
cockpit-dashboard-135-4.el7.x86_64
cockpit-bridge-135-4.el7.x86_64
cockpit-ws-135-4.el7.x86_64
cockpit-system-135-4.el7.noarch
cockpit-ovirt-dashboard-0.10.7-0.0.20.el7ev.noarch
vdsm-4.19.20-1.el7ev.x86_64
kernel-3.10.0-514.26.1.el7.x86_64
ovirt-host-deploy-1.6.6-1.el7ev.noarch
ovirt-hosted-engine-setup-2.1.3.2-1.el7ev.noarch
ovirt-hosted-engine-ha-2.1.4-1.el7ev.noarch

Steps to Reproduce:
1. Install redhat-virtualization-host-4.1-20170629.0
2. Login to cockpit via ip:9090
3. Deploy HE
4. Come to " Virtualization " page and select "Virtual Machines" tab
5. Check vms status

Actual results:
After step 5, the page "Virtual Machines" is down and has no response

Expected results:
After step 5, the page "Virtual Machines" could work normally and could check its information

Additional info:
The same issue in Firefox and Chrome browser


So, the bug's status should be changed ON_QA to ASSIGNED.
Comment 6 Red Hat Bugzilla Rules Engine 2017-07-03 23:35:34 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 8 jianwu 2017-07-19 05:25:23 EDT
I have test this bug on new build 4.1.4(redhat-virtualization-host-4.1-20170714.1)

Version-Release number of selected component (if applicable):
cockpit-ovirt-dashboard-0.10.7-0.0.21.el7ev.noarch
kernel-3.10.0-693.el7.x86_64
cockpit-ws-141-2.el7.x86_64

Test Results:
Still encounter this issue, and the page under "Virtual Machines" is down, so I will change status into ASSIGNED
Comment 9 Marek Libra 2017-07-27 04:00:48 EDT
cshao, can you please attach actual web-browser console logs? (Press F12 in FF or Chrome)
Comment 10 jianwu 2017-07-27 04:23 EDT
Created attachment 1305257 [details]
web-console log
Comment 11 jianwu 2017-07-27 04:27:06 EDT
(In reply to jianwu from comment #10)
> Created attachment 1305257 [details]
> web-console log

Hi,
I have upload related web-browser(chrome) console log as attachment 1305257 [details]

version:
redhat-virtualization-host-4.1-20170721.0 (4.1.4)
cockpit-ovirt-dashboard-0.10.7-0.0.21.el7ev.noarch

if any problems, please contact me, thanks

jianwu
Comment 12 Marek Libra 2017-07-27 04:30:48 EDT
Seems like https://gerrit.ovirt.org/#/c/79197/ did not make it to oVirt 4.1.4 which goes with cockpit-ovirt-dashboard-0.10.7-0.0.21

I verified gerrit 79197 locally from rpm and it fixed the issue for me.
Means next build for 4.1.5 shall be already ok.

Ryan, please confirm there will be next cockpit-ovirt-dashboard build for 4.1.5, thanks
Comment 13 Ryan Barry 2017-07-27 07:16:58 EDT
This has been build downstream twice since that patch was merged.

I'll make sure the patch is present, but it definitely should already be there.
Comment 15 Ryan Barry 2017-07-28 11:53:59 EDT
Sorry, Marek. I didn't see the second patch. I'll rebuild for 4.1.5
Comment 16 jianwu 2017-08-21 21:42:01 EDT
I have test this bug on redhat-virtualization-host-4.1-20170816.2

Version-Release number of selected component (if applicable):
cockpit-ws-141-4.el7.x86_64
ovirt-node-ng-nodectl-4.1.5-0.20170810.0.el7.noarch

Steps to test:
1. Install redhat-virtualization-host-4.1-20170816.2 successfully
2. Register to engine and setup VM
3. Login to cockpit via ip:9090
4. Come to " Virtualization " page and select "Virtual Machines" tab
5. Check its status

Test results:
After step 5, the page "Virtual Machines" could work normally and could check its information

So in this situation, I thinks this bug is fixed now on ovirt-4.1.5, I will change status into VERIFIED
Comment 17 jianwu 2017-08-21 21:54:48 EDT
(In reply to jianwu from comment #16)
> I have test this bug on redhat-virtualization-host-4.1-20170816.2
> 
> Version-Release number of selected component (if applicable):
> cockpit-ws-141-4.el7.x86_64
> ovirt-node-ng-nodectl-4.1.5-0.20170810.0.el7.noarch
> 
> Steps to test:
> 1. Install redhat-virtualization-host-4.1-20170816.2 successfully
> 2. Register to engine and setup VM
> 3. Login to cockpit via ip:9090
> 4. Come to " Virtualization " page and select "Virtual Machines" tab
> 5. Check its status
> 
> Test results:
> After step 5, the page "Virtual Machines" could work normally and could
> check its information
> 
> So in this situation, I thinks this bug is fixed now on ovirt-4.1.5, I will
> change status into VERIFIED

Update:

Test version:
redhat-virtualization-host-4.1-20170816.2
cockpit-ovirt-dashboard-0.10.7-0.0.23.el7ev.noarch
ockpit-ws-141-4.el7.x86_64
ovirt-node-ng-nodectl-4.1.5-0.20170810.0.el7.noarch

Note You need to log in before you can comment on or make changes to this bug.